summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-10 01:30:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-10 01:39:01 +0200
commit68a08dfbe53301fb5c15470b52185e0578b5293e (patch)
tree8bb016e1ae7684e8fdb5b857cb8a9a185eb72353 /gnu/packages
parentfe79ce3b1f34300ff3bb94238462323f887c93be (diff)
downloadguix-patches-68a08dfbe53301fb5c15470b52185e0578b5293e.tar
guix-patches-68a08dfbe53301fb5c15470b52185e0578b5293e.tar.gz
gnu: libgd: Incorporate grafted changes.
* gnu/packages/gd.scm (gd)[replacement]: Remove field. [source](patches): Add "gd-CVE-2018-5711.patch" and "gd-CVE-2018-1000222.patch". (gd/fixed): Remove variable. * gnu/packages/php.scm (gd-for-php): Remove variable. (php)[inputs]: Change GD-FOR-PHP to GD.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gd.scm16
-rw-r--r--gnu/packages/php.scm12
2 files changed, 5 insertions, 23 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 327a1f1545..1fe69577fd 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -39,7 +39,6 @@
(define-public gd
(package
(name "gd")
- (replacement gd/fixed)
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
@@ -52,7 +51,10 @@
(sha256
(base32
"0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
- (patches (search-patches "gd-fix-tests-on-i686.patch"
+
+ (patches (search-patches "gd-CVE-2018-5711.patch"
+ "gd-CVE-2018-1000222.patch"
+ "gd-fix-tests-on-i686.patch"
"gd-freetype-test-failure.patch"))))
(build-system gnu-build-system)
(arguments
@@ -92,16 +94,6 @@ most common applications of GD involve website development.")
"See COPYING file in the distribution."))
(properties '((cpe-name . "libgd")))))
-(define-public gd/fixed
- (hidden-package
- (package
- (inherit gd)
- (source (origin
- (inherit (package-source gd))
- (patches (append (origin-patches (package-source gd))
- (search-patches "gd-CVE-2018-5711.patch"
- "gd-CVE-2018-1000222.patch"))))))))
-
(define-public perl-gd
(package
(name "perl-gd")
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 4981c60554..0efbec8057 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -50,16 +50,6 @@
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:))
-(define gd-for-php
- (package
- (inherit gd)
- (source (origin
- (inherit (package-source gd))
- (patches (search-patches "gd-fix-tests-on-i686.patch"
- "gd-freetype-test-failure.patch"
- "gd-CVE-2018-5711.patch"
- "gd-CVE-2018-1000222.patch"))))))
-
(define-public php
(package
(name "php")
@@ -312,7 +302,7 @@
("curl" ,curl)
("cyrus-sasl" ,cyrus-sasl)
("freetype" ,freetype)
- ("gd" ,gd-for-php)
+ ("gd" ,gd)
("gdbm" ,gdbm)
("glibc" ,glibc)
("gmp" ,gmp)