summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-15 13:25:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-16 12:52:39 +0200
commit608e342d1f7e4f383a482fa41329080a530003ce (patch)
tree66ead15e127dae35dbde724304780f31bed97237 /gnu/packages
parentc307bb7a3f74eb758c0e2d7a529ce1babf66f41e (diff)
downloadguix-patches-608e342d1f7e4f383a482fa41329080a530003ce.tar
guix-patches-608e342d1f7e4f383a482fa41329080a530003ce.tar.gz
gnu: Add rust-hashbrown-0.11.
* gnu/packages/crates-io.scm (rust-hashbrown-0.11): New variable. (rust-hashbrown-0.9): Inherit from above.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 30 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3562112edf..9382f7c28a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19179,8 +19179,37 @@ the template engine that renders the official Rust website")
@code{#[derive(Hash32)]}.")
(license (list license:expat license:asl2.0))))
+(define-public rust-hashbrown-0.11
+ (package
+ (name "rust-hashbrown")
+ (version "0.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hashbrown" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0vkjsf5nzs7qcia5ya79j9sq2p1caz4crrncr1675wwyj3ag0pmb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-ahash" ,rust-ahash-0.7)
+ ("rust-bumpalo" ,rust-bumpalo-3)
+ ("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
+ ("rust-serde" ,rust-serde-1))))
+ (home-page "https://github.com/rust-lang/hashbrown")
+ (synopsis "Rust port of Google's SwissTable hash map")
+ (description "This package provides a Rust port of Google's SwissTable
+hash map.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-hashbrown-0.9
(package
+ (inherit rust-hashbrown-0.11)
(name "rust-hashbrown")
(version "0.9.1")
(source
@@ -19191,7 +19220,6 @@ the template engine that renders the official Rust website")
(sha256
(base32
"016dsm9s4xmxlkw2jfikm54qlz6vyk0qr280gab7kzp342jf9byp"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -19207,12 +19235,7 @@ the template engine that renders the official Rust website")
("rust-rand" ,rust-rand-0.7)
("rust-rayon" ,rust-rayon-1)
("rust-rustc-hash" ,rust-rustc-hash-1)
- ("rust-serde-test" ,rust-serde-test-1))))
- (home-page "https://github.com/rust-lang/hashbrown")
- (synopsis "Rust port of Google's SwissTable hash map")
- (description "This package provides a Rust port of Google's SwissTable
-hash map.")
- (license (list license:asl2.0 license:expat))))
+ ("rust-serde-test" ,rust-serde-test-1))))))
(define-public rust-hashbrown-0.8
(package