summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-29 16:52:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-05-03 21:49:15 +0200
commit603090d8fe1f9fb19674790d182ec03fc2bb8796 (patch)
treec32c5be7a2ac10cafa3d579ce6ab46b3cbd3deda /gnu/packages
parent8a413bcaf5dd845c6c5146a4f05e08529ab3e34f (diff)
downloadguix-patches-603090d8fe1f9fb19674790d182ec03fc2bb8796.tar
guix-patches-603090d8fe1f9fb19674790d182ec03fc2bb8796.tar.gz
gnu: Add zeromq.
* gnu/packages/networking.scm (zeromq): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5429535e5f..b9125af509 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,3 +54,26 @@ line, to logically connect serial lines on different computers, or to
establish a relatively secure environment (su and chroot) for running client
or server shell scripts with network connections. ")
(license license:gpl2)))
+
+(define-public zeromq
+ (package
+ (name "zeromq")
+ (version "4.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.zeromq.org/zeromq-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0arl8fy8d03xd5h0mgda1s5bajwg8iyh1kk4hd1420rpcxgkrj9v"))))
+ (build-system gnu-build-system)
+ (home-page "http://zeromq.org")
+ (synopsis "Library for message-based applications")
+ (description
+ "The 0MQ lightweight messaging kernel is a library which extends the
+standard socket interfaces with features traditionally provided by specialized
+messaging middle-ware products. 0MQ sockets provide an abstraction of
+asynchronous message queues, multiple messaging patterns, message
+filtering (subscriptions), seamless access to multiple transport protocols and
+more.")
+ (license license:lgpl3+)))