summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-05 17:36:56 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-16 20:08:21 +0100
commit5fa01e8aaad503939036a34e0ee79d5781f5c4f1 (patch)
tree75f9c2e4a9a417ec757bf7f656276e59a49ac092 /gnu/packages
parent5f2122fb2173f1eddab2ceca44f9eb6ae98b127a (diff)
downloadguix-patches-5fa01e8aaad503939036a34e0ee79d5781f5c4f1.tar
guix-patches-5fa01e8aaad503939036a34e0ee79d5781f5c4f1.tar.gz
gnu: Add ocaml-sexplib0.
* gnu/packages/ocaml.scm (ocaml-sexplib0): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6454343969..65df9d4ed2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4865,3 +4865,28 @@ parametrized transition systems with states represented as arrays indexed by
an arbitrary number of processes. Cache coherence protocols and mutual
exclusion algorithms are typical examples of such systems.")
(license license:asl2.0)))
+
+(define-public ocaml-sexplib0
+ (package
+ (name "ocaml-sexplib0")
+ (version "0.11.0")
+ (home-page "https://github.com/janestreet/sexplib0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07v3ggyss7xhfv14bjk1n87sr42iqwj4cgjiv2lcdfkqk49i2bmi"))))
+ (build-system dune-build-system)
+ (arguments
+ '(#:tests? #f)) ;no tests
+ (synopsis "Library containing the definition of S-expressions and some
+base converters")
+ (description "Part of Jane Street's Core library The Core suite of
+libraries is an industrial strength alternative to OCaml's standard library
+that was developed by Jane Street, the largest industrial user of OCaml.")
+(license license:expat)))