summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-01-27 16:05:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-27 19:12:07 +0100
commit5ebbedea5803fcee3d99eb15bacca838bf4c124d (patch)
tree8d264b3c7363cffb4857329114639f8e48169d80 /gnu/packages
parentdbf965dd7b76dfa50ee80e037a7404e163b9917c (diff)
downloadguix-patches-5ebbedea5803fcee3d99eb15bacca838bf4c124d.tar
guix-patches-5ebbedea5803fcee3d99eb15bacca838bf4c124d.tar.gz
gnu: Add r-castor.
* gnu/packages/cran.scm (r-castor): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dce349890a..7ca7ab0f9a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35,7 +35,7 @@
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022, 2023 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
@@ -256,6 +256,33 @@ can limit either their total size or the age of the oldest object (or both),
automatically pruning objects to maintain the constraints.")
(license license:expat)))
+(define-public r-castor
+ (package
+ (name "r-castor")
+ (version "1.7.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "castor" version))
+ (sha256
+ (base32
+ "1qbndwmzzpkzgiah0hgid9z5f9iv2j53d515bjcci1591gx1fk36"))))
+ (properties `((upstream-name . "castor")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-matrix r-naturalsort r-rcpp r-rspectra))
+ (home-page "https://cran.r-project.org/package=castor")
+ (synopsis "Efficient phylogenetics on large trees")
+ (description
+ "This tool supports analyses on massive phylogenies comprising up to
+millions of tips. Functions include pruning, rerooting, calculation of
+most-recent common ancestors, calculating distances from the tree root and
+calculating pairwise distances. In addition, this tool takes care of
+calculation of phylogenetic signal and mean trait depth (trait conservatism),
+ancestral state reconstruction and hidden character prediction of discrete
+characters, simulating and fitting models of trait evolution, fitting and
+simulating diversification models, dating trees, comparing trees, and
+reading/writing trees in Newick format.")
+ (license license:gpl2+)))
+
(define-public r-collections
(package
(name "r-collections")