summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-05-11 14:05:54 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-05-11 14:06:13 +0300
commit59e72ac8f5417199795173ed964b1304698561d5 (patch)
tree27be6b1bcbf09aa9a10a7ddf9b5c74d5c7750153 /gnu/packages
parent21ec924868786c94ed7d405dfcb9c22f21ed292e (diff)
downloadguix-patches-59e72ac8f5417199795173ed964b1304698561d5.tar
guix-patches-59e72ac8f5417199795173ed964b1304698561d5.tar.gz
gnu: Add emacs-rotate-text.
* gnu/packages/emacs-xyz.scm (emacs-rotate-text): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb40dea993..6d954d34e5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15510,3 +15510,26 @@ numbers within that region will be incremented/decremented (unlike in Vim).
It is a fork of https://github.com/cofi/evil-numbers, which is unmaintained.")
(license license:gpl3+))))
+
+(define-public emacs-rotate-text
+ (package
+ (name "emacs-rotate-text")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nschum/rotate-text.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cgxv4aibkvv6lnssynn0438a615fz3zq8hg9sb0lhfgsr99pxln"))))
+ (build-system emacs-build-system)
+ (home-page "http://nschum.de/src/emacs/rotate-text/")
+ (synopsis "Cycle through words, symbols and patterns in Emacs")
+ (description "@code{rotate-text} allows you rotate to commonly
+interchanged text with a single keystroke. For example, you can toggle
+between \"frame-width\" and \"frame-height\", between \"public\",
+\"protected\" and \"private\" and between \"variable1\", \"variable2\" through
+\"variableN\".")
+ (license license:gpl2+)))