summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2017-02-18 11:24:41 +0300
committerAlex Kost <alezost@gmail.com>2017-02-27 16:44:58 +0300
commit59d04f63dfe8b68906e4cccc60ca27cbd546db78 (patch)
treeb2ae4e4831b647bd2ae8b5f25d82fec85dcde87d /gnu/packages
parent7994250fdb7ce786a72278554d85fccb6d152e73 (diff)
downloadguix-patches-59d04f63dfe8b68906e4cccc60ca27cbd546db78.tar
guix-patches-59d04f63dfe8b68906e4cccc60ca27cbd546db78.tar.gz
gnu: emacs: Move "guix-emacs.el" to "aux-files".
* emacs/guix-emacs.el: Rename to... * gnu/packages/aux-files/emacs/guix-emacs.el: ... this. * Makefile.am (AUX_FILES): Add it. * gnu/packages/emacs.scm (emacs)[inputs]: Remove 'guix' source. [native-inputs]: Add "guix-emacs.el" auxiliary file. [arguments]: Adjust 'install-site-start' phase accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/aux-files/emacs/guix-emacs.el123
-rw-r--r--gnu/packages/emacs.scm20
2 files changed, 131 insertions, 12 deletions
diff --git a/gnu/packages/aux-files/emacs/guix-emacs.el b/gnu/packages/aux-files/emacs/guix-emacs.el
new file mode 100644
index 0000000000..099261a013
--- /dev/null
+++ b/gnu/packages/aux-files/emacs/guix-emacs.el
@@ -0,0 +1,123 @@
+;;; guix-emacs.el --- Emacs packages installed with Guix
+
+;; Copyright © 2014, 2015, 2016 Alex Kost <alezost@gmail.com>
+
+;; This file is part of GNU Guix.
+
+;; GNU Guix is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation, either version 3 of the License, or
+;; (at your option) any later version.
+
+;; GNU Guix is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+
+;; You should have received a copy of the GNU General Public License
+;; along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+;;; Commentary:
+
+;; This file provides auxiliary code for working with Emacs packages
+;; installed with Guix.
+
+;;; Code:
+
+(require 'cl-lib)
+(unless (require 'guix-profiles nil t)
+ (defvar guix-user-profile (expand-file-name "~/.guix-profile")))
+
+(defcustom guix-package-enable-at-startup t
+ "If non-nil, activate Emacs packages installed in a user profile.
+Set this variable to nil before requiring `guix-emacs' file to
+avoid loading autoloads of Emacs packages installed in
+`guix-user-profile'."
+ :type 'boolean
+ :group 'guix)
+
+(defvar guix-emacs-autoloads nil
+ "List of the last loaded Emacs autoloads.")
+
+(defvar guix-emacs-autoloads-regexp
+ (rx (group (* any) "-autoloads")
+ ".el" (zero-or-one "c") string-end)
+ "Regexp to match Emacs 'autoloads' file.")
+
+(defun guix-emacs-directory (&optional profile)
+ "Return directory with Emacs packages installed in PROFILE.
+If PROFILE is nil, use `guix-user-profile'."
+ (expand-file-name "share/emacs/site-lisp"
+ (or profile guix-user-profile)))
+
+(defun guix-emacs-find-autoloads (directory)
+ "Return a list of Emacs 'autoloads' files in DIRECTORY.
+The files in the list do not have extensions (.el, .elc)."
+ (cl-remove-duplicates
+ (delq nil
+ (mapcar (lambda (file)
+ (when (string-match guix-emacs-autoloads-regexp file)
+ (match-string 1 file)))
+ (directory-files directory 'full-name nil 'no-sort)))
+ :test #'string=))
+
+(defun guix-emacs-subdirs (directory)
+ "Return list of DIRECTORY subdirectories."
+ (cl-remove-if (lambda (file)
+ (or (string-match-p (rx "/." string-end) file)
+ (string-match-p (rx "/.." string-end) file)
+ (not (file-directory-p file))))
+ (directory-files directory 'full-name nil 'no-sort)))
+
+(defun guix-emacs-directories (&optional profile)
+ "Return the list of directories under PROFILE that contain Emacs packages.
+This includes both `share/emacs/site-lisp/guix.d/PACKAGE'
+sub-directories and `share/emacs/site-lisp' itself.
+
+If PROFILE is nil, use `guix-user-profile'.
+Return nil, if Emacs packages are not installed in PROFILE."
+ (let ((root-dir (guix-emacs-directory (or profile guix-user-profile))))
+ (when (file-directory-p root-dir)
+ (let* ((pkgs-dir (expand-file-name "guix.d" root-dir))
+ (pkgs-dirs (when (file-directory-p pkgs-dir)
+ (guix-emacs-subdirs pkgs-dir))))
+ (cons root-dir pkgs-dirs)))))
+
+;;;###autoload
+(defun guix-emacs-autoload-packages (&rest profiles)
+ "Autoload Emacs packages installed in PROFILES.
+If PROFILES are not specified, use a default user and system
+profiles.
+
+'Autoload' means add directories with Emacs packages to
+`load-path' and load 'autoloads' files matching
+`guix-emacs-autoloads-regexp'."
+ (interactive (list (if (fboundp 'guix-profile-prompt)
+ (funcall 'guix-profile-prompt)
+ guix-user-profile)))
+ (let ((profiles (or profiles
+ (list "/run/current-system/profile"
+ guix-user-profile))))
+ (dolist (profile profiles)
+ (let ((dirs (guix-emacs-directories profile)))
+ (when dirs
+ (let* ((autoloads (cl-mapcan #'guix-emacs-find-autoloads
+ dirs))
+ (new-autoloads (cl-nset-difference autoloads
+ guix-emacs-autoloads
+ :test #'string=)))
+ (dolist (dir dirs)
+ (cl-pushnew (directory-file-name dir)
+ load-path
+ :test #'string=))
+ (dolist (file new-autoloads)
+ (load file 'noerror))
+ (setq guix-emacs-autoloads
+ (append new-autoloads guix-emacs-autoloads))))))))
+
+(when guix-package-enable-at-startup
+ (guix-emacs-autoload-packages))
+
+(provide 'guix-emacs)
+
+;;; guix-emacs.el ends here
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 863624fc0f..3e722c326b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -133,19 +133,15 @@
(("/bin/pwd")
"pwd"))))
(add-after 'install 'install-site-start
- ;; Copy guix-emacs.el from Guix and add it to site-start.el. This
- ;; way, Emacs packages provided by Guix and installed in
+ ;; Use 'guix-emacs' in "site-start.el". This way, Emacs packages
+ ;; provided by Guix and installed in
;; ~/.guix-profile/share/emacs/site-lisp/guix.d/PACKAGE-VERSION are
;; automatically found.
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((guix-src (assoc-ref inputs "guix-src"))
- (out (assoc-ref outputs "out"))
- (lisp-dir (string-append out "/share/emacs/site-lisp"))
- (unpack (assoc-ref %standard-phases 'unpack)))
- (mkdir "guix")
- (with-directory-excursion "guix"
- (apply unpack (list #:source guix-src))
- (install-file "emacs/guix-emacs.el" lisp-dir))
+ (let* ((out (assoc-ref outputs "out"))
+ (lisp-dir (string-append out "/share/emacs/site-lisp")))
+ (copy-file (assoc-ref inputs "guix-emacs.el")
+ (string-append lisp-dir "/guix-emacs.el"))
(with-output-to-file (string-append lisp-dir "/site-start.el")
(lambda ()
(display "(require 'guix-emacs nil t)")))
@@ -175,13 +171,13 @@
("libsm" ,libsm)
("alsa-lib" ,alsa-lib)
("dbus" ,dbus)
- ("guix-src" ,(package-source guix))
;; multilingualization support
("libotf" ,libotf)
("m17n-lib" ,m17n-lib)))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("guix-emacs.el" ,(search-auxiliary-file "emacs/guix-emacs.el"))
+ ("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
(native-search-paths