summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-06-05 23:14:31 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-06 00:25:49 +0200
commit59ce8276182891919baad2c306c1d632fff3e7e6 (patch)
treee332f83e37fba7f0922c7c54ddcf8ae13d045214 /gnu/packages
parent524c64152a8458915f42eb4a74b764eb2ab93966 (diff)
downloadguix-patches-59ce8276182891919baad2c306c1d632fff3e7e6.tar
guix-patches-59ce8276182891919baad2c306c1d632fff3e7e6.tar.gz
gnu: Add soapyhackrf.
* gnu/packages/radio.scm (soapyhackrf): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/radio.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index a3cbe99380..18545bae79 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -287,6 +287,31 @@ with this package. E.g.: @code{(udev-rules-service 'airspyhf airspyhf)}")
defined radio hardware devices with a common API.")
(license license:boost1.0)))
+(define-public soapyhackrf
+ (package
+ (name "soapyhackrf")
+ (version "0.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapyHackRF")
+ (commit (string-append "soapy-hackrf-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1awn89z462500gb3fjb7x61b1znkjri9n1d39bqfip1qk4s11pxc"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("hackrf" ,hackrf)
+ ("soapysdr" ,soapysdr)))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
+ (synopsis "SoapySDR HackRF module")
+ (description
+ "This package provides HackRF devices support to the SoapySDR library.")
+ (license license:expat)))
+
(define-public chirp
(package
(name "chirp")