summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-01 15:37:23 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-03-11 20:48:03 +0200
commit532fc2fbaf8f3b13eb1bfc1024a31e957a68cffd (patch)
treee28c20e01024e8c2e4fb1adc1df66e7ad705aec2 /gnu/packages
parentcfa564bcef30cb0018a63c7c33b62b865b9fc731 (diff)
downloadguix-patches-532fc2fbaf8f3b13eb1bfc1024a31e957a68cffd.tar
guix-patches-532fc2fbaf8f3b13eb1bfc1024a31e957a68cffd.tar.gz
gnu: Add python-prawcore.
* gnu/packages/python-web.scm (python-prawcore): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ab90092762..9415b8cee9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -91,6 +91,31 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-prawcore
+ (package
+ (name "python-prawcore")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "prawcore" version))
+ (sha256
+ (base32 "1l9nrn4s03xl8fvkyybdk86bm9cyyk43alkxf9g014a9ynvdk65l"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-betamax" ,python-betamax)
+ ("python-betamax-matchers" ,python-betamax-matchers)
+ ("python-betamax-serializers" ,python-betamax-serializers)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-testfixtures" ,python-testfixtures)))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (synopsis "Core component of PRAW")
+ (description "PRAWcore is a low-level communication layer used by PRAW.")
+ (home-page "https://praw.readthedocs.io/en/latest/")
+ (license license:bsd-2)))
+
(define-public python-aiohttp
(package
(name "python-aiohttp")