summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-14 20:08:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-14 20:08:36 +0200
commit52cb7748cbdb61b87e5c2bbc99e12284f21a304d (patch)
tree128cbddde41c49778099d04bd836ca881cc18a45 /gnu/packages
parent828d3765a71ce1b74d1ab122c84d5c16eabf98b9 (diff)
downloadguix-patches-52cb7748cbdb61b87e5c2bbc99e12284f21a304d.tar
guix-patches-52cb7748cbdb61b87e5c2bbc99e12284f21a304d.tar.gz
gnu: curl: Remove unused input.
* gnu/packages/curl.scm (curl)[inputs]: Remove LIBSSH2-1.8.0. * gnu/packages/ssh.scm (libssh2-1.8.0): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/curl.scm5
-rw-r--r--gnu/packages/ssh.scm18
2 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index a83760adc1..9a13815e3d 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -64,11 +64,6 @@
"doc")) ;1.2 MiB of man3 pages
(inputs `(("gnutls" ,gnutls)
("libidn" ,libidn)
- ;; TODO XXX <https://bugs.gnu.org/34927>
- ;; Curl doesn't actually use or refer to libssh2 because the build
- ;; is not configured with '--with-libssh2'. Remove this input when
- ;; a mass rebuild is appropriate (e.g. core-updates).
- ("libssh2" ,libssh2-1.8.0)
("openldap" ,openldap)
("mit-krb5" ,mit-krb5)
("nghttp2" ,nghttp2 "lib")
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index e887cd7e70..a763c6aba2 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -143,24 +143,6 @@ a server that supports the SSH-2 protocol.")
(license license:bsd-3)
(home-page "https://www.libssh2.org/")))
-;; XXX A hidden special obsolete libssh2 for temporary use in the curl package.
-;; <https://bugs.gnu.org/34927>
-(define-public libssh2-1.8.0
- (hidden-package
- (package
- (inherit libssh2)
- (version "1.8.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://www.libssh2.org/download/libssh2-"
- version ".tar.gz"))
- (sha256
- (base32
- "1m3n8spv79qhjq4yi0wgly5s5rc8783jb1pyra9bkx1md0plxwrr"))
- (patches
- (search-patches "libssh2-fix-build-failure-with-gcrypt.patch")))))))
-
(define-public openssh
(package
(name "openssh")