summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-30 14:34:40 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-30 15:19:32 +0100
commit528ea990c3a815cb4b0ded913ea22cdc778839bd (patch)
tree5803e0a9b9f6a1a384b5bb306a0899f13dc7e65e /gnu/packages
parent398747f8f11dc011799da1c2384aa201488a4595 (diff)
downloadguix-patches-528ea990c3a815cb4b0ded913ea22cdc778839bd.tar
guix-patches-528ea990c3a815cb4b0ded913ea22cdc778839bd.tar.gz
gnu: Use 'this-package' as a native input instead of 'self-native-input?'.
* gnu/packages/file.scm (file)[self-native-input?]: Remove. [native-inputs]: New field. * gnu/packages/guile.scm (guile-1.8)[self-native-input?]: Remove. [native-inputs]: New field. (guile-2.0)[self-native-input?]: Remove. [native-inputs]: Add THIS-PACKAGE when (%current-target-system) is true. * gnu/packages/ncurses.scm (ncurses)[self-native-input?]: Remove. [native-inputs]: Add THIS-PACKAGE when (%current-target-system) is true. * gnu/packages/python-xyz.scm (python-file)[self-native-input?]: Remove. [native-inputs]: New field.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/file.scm4
-rw-r--r--gnu/packages/guile.scm18
-rw-r--r--gnu/packages/ncurses.scm8
-rw-r--r--gnu/packages/python-xyz.scm4
4 files changed, 23 insertions, 11 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 4518c8d3dc..d04357023d 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -43,7 +43,9 @@
;; When cross-compiling, this package depends upon a native install of
;; itself.
- (self-native-input? #t)
+ (native-inputs (if (%current-target-system)
+ `(("self" ,this-package))
+ '()))
(synopsis "File type guesser")
(description
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index daeadca610..5903bcabaa 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -103,6 +103,12 @@
(substitute* "ice-9/popen.scm"
(("/bin/sh") (which "sh")))
#t)))))
+
+ ;; When cross-compiling, a native version of Guile itself is needed.
+ (native-inputs (if (%current-target-system)
+ `(("self" ,this-package))
+ '()))
+
(inputs `(("gawk" ,gawk)
("readline" ,readline)))
@@ -111,9 +117,6 @@
(propagated-inputs `(("gmp" ,gmp)
("libltdl" ,libltdl)))
- ;; When cross-compiling, a native version of Guile itself is needed.
- (self-native-input? #t)
-
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")
@@ -141,7 +144,12 @@ without requiring the source code to be rewritten.")
(base32
"10lxc6l5alf3lzbs3ihnbfy6dfcrsyf8667wa57f26vf4mk2ai78"))))
(build-system gnu-build-system)
- (native-inputs `(("pkgconfig" ,pkg-config)))
+
+ ;; When cross-compiling, a native version of Guile itself is needed.
+ (native-inputs `(,@(if (%current-target-system)
+ `(("self" ,this-package))
+ '())
+ ("pkgconfig" ,pkg-config)))
(inputs `(("libffi" ,libffi)
,@(libiconv-if-needed)
@@ -165,8 +173,6 @@ without requiring the source code to be rewritten.")
("bdw-gc" ,libgc)
("gmp" ,gmp)))
- (self-native-input? #t)
-
(outputs '("out" "debug"))
(arguments
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 9b5498688b..a35ff9b400 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 ng0 <ng0@n0.is>
@@ -196,9 +196,11 @@
,patch-makefile-phase)
(add-after 'unpack 'remove-unneeded-shebang
,remove-shebang-phase)))))
- (self-native-input? #t) ; for `tic'
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(,@(if (%current-target-system)
+ `(("self" ,this-package)) ;for `tic'
+ '())
+ ("pkg-config" ,pkg-config)))
(native-search-paths
(list (search-path-specification
(variable "TERMINFO_DIRS")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f392b52235..03a83022a1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6875,7 +6875,9 @@ Python's @code{ctypes} foreign function interface (FFI).")
(string-append "'" file "/lib/libmagic.so'")))
#t))))))
(inputs `(("file" ,file)))
- (self-native-input? #f)
+ (native-inputs (if (%current-target-system)
+ `(("self" ,this-package))
+ '()))
(synopsis "Python bindings to the libmagic file type guesser. Note that
this module and the python-magic module both provide a \"magic.py\" file;
these two modules, which are different and were developed separately, both