summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-01 02:31:52 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-01 03:14:01 +0100
commit4d441ca1743a985eeba33027f864b9b136c5e9e1 (patch)
tree2d9b781b8ee61c86f604a47d54dc1e6cc13c4547 /gnu/packages
parent50db7df4d26bef655d744de5ae1e6441d1e9feeb (diff)
downloadguix-patches-4d441ca1743a985eeba33027f864b9b136c5e9e1.tar
guix-patches-4d441ca1743a985eeba33027f864b9b136c5e9e1.tar.gz
gnu: thermald: Update to 1.9.
* gnu/packages/admin.scm (thermald): Update to 1.9. [source]: Remove patch. * packages/patches/thermald-make-int-max32-visible.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm6
-rw-r--r--gnu/packages/patches/thermald-make-int-max32-visible.patch24
2 files changed, 2 insertions, 28 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d00e887071..5a135c5829 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3015,7 +3015,7 @@ make it a perfect utility on modern distros.")
(define-public thermald
(package
(name "thermald")
- (version "1.8")
+ (version "1.9")
(source
(origin
(method git-fetch)
@@ -3024,9 +3024,7 @@ make it a perfect utility on modern distros.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1g1l7k8yxj8bl1ysdx8v6anv1s7xk9j072y44gwki70dy48n7j92"))
- (patches
- (search-patches "thermald-make-int-max32-visible.patch"))))
+ (base32 "1ajhivl9jifcf12nbk281yayk7666v65m249aclyli0bz1kh8cfs"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/patches/thermald-make-int-max32-visible.patch b/gnu/packages/patches/thermald-make-int-max32-visible.patch
deleted file mode 100644
index eddbb23547..0000000000
--- a/gnu/packages/patches/thermald-make-int-max32-visible.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 5fb947886bf1e40475edf930fb2b284c24c8cb9a Mon Sep 17 00:00:00 2001
-From: Sanel Zukan <karijes@users.sourceforge.net>
-Date: Sun, 23 Dec 2018 00:04:34 +0100
-Subject: [PATCH] Make sure INT_MAX32 is visible.
-
----
- src/thd_trip_point.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/thd_trip_point.h b/src/thd_trip_point.h
-index 0eedc95..89eb083 100644
---- a/src/thd_trip_point.h
-+++ b/src/thd_trip_point.h
-@@ -29,6 +29,10 @@
- #include "thd_sys_fs.h"
- #include "thd_preference.h"
- #include "thd_cdev.h"
-+
-+#define __STDC_LIMIT_MACROS
-+#include <stdint.h>
-+
- #include <time.h>
- #include <vector>
- #include <algorithm> // std::sort