summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-20 14:55:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-24 11:41:20 +0300
commit49996b2763ef92f03aae8709c3494eb129c03178 (patch)
tree1ce1829c103e9d837648c465b70fd0ac975f8091 /gnu/packages
parent6f3a9d4c9b3cb67ba4a7b9cb2eb00394a06ad36c (diff)
downloadguix-patches-49996b2763ef92f03aae8709c3494eb129c03178.tar
guix-patches-49996b2763ef92f03aae8709c3494eb129c03178.tar.gz
gnu: Add julia-gr.
* gnu/packages/julia-xyz.scm (julia-gr): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 58f58f36ec..1db5a1bc58 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1895,6 +1895,28 @@ analysis of dense matrices. The diagonal eigen-decomposition of normal
matrices the Schur form is often more useful.")
(license license:expat)))
+(define-public julia-gr
+ (package
+ (name "julia-gr")
+ (version "0.58.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jheinen/GR.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18zxa1w2wmrf44c5l10qbh99zjdp7h94gxlymh47cf5kj5fc4xmx"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-gr-jll" ,julia-gr-jll)))
+ (home-page "https://github.com/jheinen/GR.jl")
+ (synopsis "Plotting for Julia based on GR")
+ (description "This module provides a Julia interface to GR, a framework for
+visualisation applications.")
+ (license license:expat)))
+
(define-public julia-graphics
(package
(name "julia-graphics")