summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-04-06 17:07:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-04-06 17:12:15 +0200
commit482959ffa4601eff181688ec0e7ecaf68fe799a0 (patch)
tree52f11c3dc011d83b2f9640fca30cb56432c38932 /gnu/packages
parent262ee8eae27d14b1469b41d07c6a2cbfc7f4905d (diff)
downloadguix-patches-482959ffa4601eff181688ec0e7ecaf68fe799a0.tar
guix-patches-482959ffa4601eff181688ec0e7ecaf68fe799a0.tar.gz
gnu: sambamba: Update to 0.6.7-10-g223fa20.
* gnu/packages/bioinformatics.scm (sambamba)[source]: Fetch from git. [arguments]: Disable parallel build; rename build phase "place-biod" to "place-biod-and-undead"; add build phase "fix-ldc-version"; adjust phase "unbundle-prerequisites". [native-inputs]: Add python2-minimal; update biod sources; add undead sources.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm51
1 files changed, 36 insertions, 15 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 88aa48cd9e..0e9e6b13fd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10999,34 +10999,41 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
(define-public sambamba
(package
(name "sambamba")
- (version "0.6.5")
+ (version "0.6.7-10-g223fa20")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/lomereiter/sambamba/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lomereiter/sambamba.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "17076gijd65a3f07zns2gvbgahiz5lriwsa6dq353ss3jl85d8vy"))))
+ "1zb9hrxglxqh13ava9wwri30cvf85hjnbn8ccnr8l60a3k5avczn"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; there is no test target
- #:make-flags
- '("D_COMPILER=ldc2"
- ;; Override "--compiler" flag only.
- "D_FLAGS=--compiler=ldc2 -IBioD -g -d"
- "sambamba-ldmd2-64")
+ `(#:tests? #f ; there is no test target
+ #:parallel-build? #f ; not supported
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-after 'unpack 'place-biod
+ (add-after 'unpack 'fix-ldc-version
+ (lambda _
+ (substitute* "gen_ldc_version_info.py"
+ (("/usr/bin/env.*") (which "python")))
+ (substitute* "Makefile"
+ (("\\$\\(shell which ldmd2\\)") (which "ldmd2")))
+ #t))
+ (add-after 'unpack 'place-biod-and-undead
(lambda* (#:key inputs #:allow-other-keys)
(copy-recursively (assoc-ref inputs "biod") "BioD")
+ (copy-recursively (assoc-ref inputs "undead") "undeaD")
#t))
(add-after 'unpack 'unbundle-prerequisites
(lambda _
(substitute* "Makefile"
+ (("htslib/libhts.a lz4/lib/liblz4.a")
+ "-L-lhts -L-llz4")
((" htslib-static lz4-static") ""))
#t))
(replace 'install
@@ -11039,8 +11046,9 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
(native-inputs
`(("ldc" ,ldc)
("rdmd" ,rdmd)
+ ("python" ,python2-minimal)
("biod"
- ,(let ((commit "1248586b54af4bd4dfb28ebfebfc6bf012e7a587"))
+ ,(let ((commit "c778e4f2d8bacea7499283ce39f5577b232732c6"))
(origin
(method git-fetch)
(uri (git-reference
@@ -11051,7 +11059,20 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
"-checkout"))
(sha256
(base32
- "1m8hi1n7x0ri4l6s9i0x6jg4z4v94xrfdzp7mbizdipfag0m17g3")))))))
+ "1z90562hg47i63gx042wb3ak2vqjg5z7hwgn9bp2pdxfg3nxrw37")))))
+ ("undead"
+ ,(let ((commit "92803d25c88657e945511f0976a0c79d8da46e89"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlang/undeaD.git")
+ (commit commit)))
+ (file-name (string-append "undead-"
+ (string-take commit 9)
+ "-checkout"))
+ (sha256
+ (base32
+ "0vq6n81vzqvgphjw54lz2isc1j8lcxwjdbrhqz1h5gwrvw9w5138")))))))
(inputs
`(("lz4" ,lz4)
("htslib" ,htslib-for-sambamba)))