summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorYovan Naumovski <yovan@gorski.stream>2023-02-25 22:17:19 +0200
committerChristopher Baines <mail@cbaines.net>2023-03-14 10:36:32 +0000
commit476e1b270e657a82ef3a8d253d694d07a766cde4 (patch)
treee2a11deddeefd259623e3de8845cb3ee624f5572 /gnu/packages
parent056f743718370e182379260ac0774fa41fca77ad (diff)
downloadguix-patches-476e1b270e657a82ef3a8d253d694d07a766cde4.tar
guix-patches-476e1b270e657a82ef3a8d253d694d07a766cde4.tar.gz
gnu: mruby: Update to 3.2.0.
* gnu/packages/ruby.scm (mruby): Update to 3.2.0. [arguments]: Remove unnecessary substitutions in the 'disable-broken-tests phase. [description]: Update. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2e8d4038de..8f38389719 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -259,7 +260,7 @@ a focus on simplicity and productivity.")
(define-public mruby
(package
(name "mruby")
- (version "2.1.2")
+ (version "3.2.0")
(source
(origin
(method git-fetch)
@@ -269,7 +270,7 @@ a focus on simplicity and productivity.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fhfv8pi7i8jn2vgk2n2rjnbnfa12nhj514v8i4k353n7q4pmkh3"))))
+ "0c0scaqbnywrd9z1z4rnnj345rjc3vbklszm0rc6y6rzx1cxnsij"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -287,13 +288,9 @@ a focus on simplicity and productivity.")
(substitute* "mrbgems/mruby-io/test/io.rb"
(("assert\\('IO.popen.+$" m)
(string-append m "skip \"Hangs in the Guix build environment\"\n"))
- (("assert\\('IO#isatty.+$" m)
- (string-append m "skip \"Disable for Guix; there is no /dev/tty\"\n"))
;; This one is really weird. The *expected* output is all wrong.
(("assert\\('`cmd`.*" m)
- (string-append m "skip \"Disable for Guix\"\n"))
- (("echo foo")
- (string-append (which "echo") " foo")))
+ (string-append m "skip \"Disable for Guix\"\n")))
#t))
;; There is no install target
(replace 'install
@@ -311,8 +308,8 @@ a focus on simplicity and productivity.")
(home-page "https://github.com/mruby/mruby")
(synopsis "Lightweight Ruby")
(description "mruby is the lightweight implementation of the Ruby
-language. Its syntax is Ruby 1.9 compatible. mruby can be linked and
-embedded within your application.")
+language. Its syntax is Ruby 3.x compatible except for pattern
+matching. mruby can be linked and embedded within your application.")
(license license:expat)))
(define-public ruby-commander