summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorfesoj000 <fesoj000@gmail.com>2022-03-27 00:34:11 +0100
committerLudovic Courtès <ludo@gnu.org>2022-04-11 13:47:48 +0200
commit469f85d206604fdf7129ce4cfd0883b402297395 (patch)
treeca77436242fe6b0e020d2dbf42baf6c421802097 /gnu/packages
parent24851bf6f9afa29074b4b88f990704b2f386e202 (diff)
downloadguix-patches-469f85d206604fdf7129ce4cfd0883b402297395.tar
guix-patches-469f85d206604fdf7129ce4cfd0883b402297395.tar.gz
gnu: Add libnetfilter-conntrack
* gnu/packages/linux.scm (libnetfilter-conntrack): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b31fe0a580..4824f8e7b8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7295,6 +7295,33 @@ infrastructure such as the existing hooks, the connection tracking system, the
userspace queueing component and the logging subsystem.")
(license license:gpl2)))
+(define-public libnetfilter-conntrack
+ (package
+ (name "libnetfilter-conntrack")
+ (version "1.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://netfilter.org/projects/"
+ "libnetfilter_conntrack/files/"
+ "libnetfilter_conntrack-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1ky1mqgnplw2h9jf0kn0a69d94jkydhbiipng9l2hdcj13h3pl8c"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list libnfnetlink libmnl))
+ (synopsis "Library for kernel connection tracking state table")
+ (description "libnetfilter_conntrack is a userspace library providing a
+programming interface (API) to the in-kernel connection tracking state table.
+The library libnetfilter_conntrack has been previously known as
+libnfnetlink_conntrack and libctnetlink. This library is currently used by
+conntrack-tools among many other applications.")
+ (home-page "https://netfilter.org/projects/libnetfilter_conntrack/index.html")
+ (supported-systems (filter target-linux? %supported-systems))
+ (license license:gpl2+)))
+
(define-public proot
(package
(name "proot")