summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-15 18:10:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-15 18:12:45 +0200
commit44469ffd83f8dd48355954eee50002efbbe58503 (patch)
tree64c94af13ee5442da7bc9eba8890f20ca286a8f6 /gnu/packages
parent3f396ec339e0b1a4b553587a4108829ac4d88c48 (diff)
downloadguix-patches-44469ffd83f8dd48355954eee50002efbbe58503.tar
guix-patches-44469ffd83f8dd48355954eee50002efbbe58503.tar.gz
gnu: font-abattis-cantarell: Update variable name.
* gnu/packages/fonts.scm (font-cantarell): Rename to… (font-abattis-cantarell): …this. * gnu/packages/gnome.scm (gnome)[propagated-inputs]: Adjust accordingly. * gnu/packages/mate.scm (mate)[inputs]: Likewise. * gnu/services/xorg.scm (<gdm-configuration>): Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fonts.scm6
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/gtk.scm2
-rw-r--r--gnu/packages/mate.scm2
4 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 5cf2393177..de1acc5a75 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -197,10 +197,10 @@ includes lining and old-style numerals, tabular and proportional. Greek,
Cyrillic, Canadian Syllabics and most Latin based languages are supported.")
(license license:cc0)))
-(define-public font-cantarell
+(define-public font-abattis-cantarell
(package
(name "font-abattis-cantarell")
- (version "0.301")
+ (version "0.303")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/cantarell-fonts/"
@@ -208,7 +208,7 @@ Cyrillic, Canadian Syllabics and most Latin based languages are supported.")
"/cantarell-fonts-" version ".tar.xz"))
(sha256
(base32
- "10sycxscs9kzl451mhygyj2qj8qlny8pamskb86np7izq05dnd9x"))))
+ "11sycxscs9kzl451mhygyj2qj8qlny8pamskb86np7izq05dnd9x"))))
(build-system meson-build-system)
(native-inputs
`(("gettext" ,gettext-minimal))) ; for msgfmt
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 17fb2e0146..20c0be8d9d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9242,7 +9242,7 @@ world.")
;; Packages not part of GNOME proper but that are needed for a good
;; experience. See <https://bugs.gnu.org/39646>.
;; XXX: Find out exactly which ones are needed and why.
- ("font-cantarell" ,font-cantarell)
+ ("font-abattis-cantarell" ,font-abattis-cantarell)
("font-dejavu" ,font-dejavu)
("at-spi2-core" ,at-spi2-core)
("dbus" ,dbus)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2a587d9e32..243a7de08c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -331,7 +331,7 @@ applications.")
(add-after 'unpack 'disable-cantarell-tests
(lambda _
(substitute* "tests/meson.build"
- ;; XXX FIXME: These tests require "font-cantarell", but
+ ;; XXX FIXME: These tests require "font-abattis-cantarell", but
;; adding it here would introduce a circular dependency.
(("\\[ 'test-harfbuzz'.*") "")
(("\\[ 'test-itemize'.*") "")
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 82b2d6e0fd..ede37fe5d9 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1545,7 +1545,7 @@ used to bring up authentication dialogs.")
("dconf" ,dconf)
("engrampa" ,engrampa)
("eom" ,eom)
- ("font-cantarell" ,font-cantarell)
+ ("font-abattis-cantarell" ,font-abattis-cantarell)
("glib-networking" ,glib-networking)
("gnome-keyring" ,gnome-keyring)
("gvfs" ,gvfs)