summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 21:30:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:11 +0300
commit4275727ac5ab29c833fd6306d153cdc4e9164dd6 (patch)
treed2cc58b5d1ff85c5bddf6b28c8c308bb7883ce9e /gnu/packages
parent54da48e2cea47b230f9306dcb33e41dfa934a84e (diff)
downloadguix-patches-4275727ac5ab29c833fd6306d153cdc4e9164dd6.tar
guix-patches-4275727ac5ab29c833fd6306d153cdc4e9164dd6.tar.gz
gnu: python-natsort: Honor the #:tests? flag.
* gnu/packages/python-xyz.scm (python-natsort)[arguments]: Adjust the custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8b0aae76ac..de8c7de6e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18195,8 +18195,9 @@ JSON) codec.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-v"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-v")))))))
(native-inputs
(list python-hypothesis python-pytest-cov python-pytest-mock
python-pytest))