summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-01 12:57:06 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-01 13:16:45 +0100
commit38bbd61df1e647b475815f1f35f79e97799f2824 (patch)
tree84bb0e758cd05b3189d2d2d8ea96447318cd9fbc /gnu/packages
parentcb09fb24eef9480188ef6b7c9411cd37bfc3b494 (diff)
downloadguix-patches-38bbd61df1e647b475815f1f35f79e97799f2824.tar
guix-patches-38bbd61df1e647b475815f1f35f79e97799f2824.tar.gz
gnu: Fix invalid `license' fields.
* gnu/packages/acl.scm (acl): Change `license' field to refer to the `license' objects. * gnu/packages/attr.scm (attr): Likewise. * gnu/packages/compression.scm (xz): Likewise. * gnu/packages/global.scm (global): Likewise. * gnu/packages/linux.scm (linux-libre-headers): Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/acl.scm2
-rw-r--r--gnu/packages/attr.scm4
-rw-r--r--gnu/packages/compression.scm4
-rw-r--r--gnu/packages/global.scm2
-rw-r--r--gnu/packages/linux.scm2
5 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 1cba608c8c..14579e9ea9 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -63,4 +63,4 @@
"Library and tools for manipulating access control lists")
(description
"Library and tools for manipulating access control lists.")
- (license '(gpl2+ lgpl2.1+))))
+ (license (list gpl2+ lgpl2.1+))))
diff --git a/gnu/packages/attr.scm b/gnu/packages/attr.scm
index 2f8a0e0e65..254792f4ed 100644
--- a/gnu/packages/attr.scm
+++ b/gnu/packages/attr.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,4 +74,4 @@
"Library and tools for manipulating extended attributes")
(description
"Portable library and tools for manipulating extended attributes.")
- (license '(gpl2+ lgpl2.1+))))
+ (license (list gpl2+ lgpl2.1+))))
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index dc00f323ce..086900990b 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -171,7 +171,7 @@ been modified quite a lot to be suitable for XZ Utils. The primary
compression algorithm is currently LZMA2, which is used inside the .xz
container format. With typical files, XZ Utils create 30 % smaller output
than gzip and 15 % smaller output than bzip2.")
- (license '(license:gpl2+ license:lgpl2.1+)) ; bits of both
+ (license (list license:gpl2+ license:lgpl2.1+)) ; bits of both
(home-page "http://tukaani.org/xz/")))
(define-public lzo
diff --git a/gnu/packages/global.scm b/gnu/packages/global.scm
index 592aefc66e..b604ab6478 100644
--- a/gnu/packages/global.scm
+++ b/gnu/packages/global.scm
@@ -55,4 +55,4 @@ subdirectories, many #ifdef and many main() functions. It is similar
to ctags or etags but is different from them at the point of
independence of any editor. It runs on a UNIX (POSIX) compatible
operating system like GNU and BSD.")
- (license "GPLv3+")))
+ (license gpl3+)))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index de6d53a0d9..4d51d8b310 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -80,7 +80,7 @@
#:tests? #f))
(synopsis "GNU Linux-Libre kernel headers")
(description "Headers of the Linux-Libre kernel.")
- (license "GPLv2")
+ (license gpl2)
(home-page "http://www.gnu.org/software/linux-libre/"))))
(define-public linux-pam