summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRyan Moe <ryan.moe@gmail.com>2017-07-22 07:18:42 -0700
committerLeo Famulari <leo@famulari.name>2017-07-22 20:04:53 -0400
commit36378bd57ec31ba2bbedbdbdbd77b5b0f82f3b8a (patch)
tree758114583ca1b59d785ee8d6a0548131955801b3 /gnu/packages
parente745221408c92df511c383dec6c78ef6c5e1d177 (diff)
downloadguix-patches-36378bd57ec31ba2bbedbdbdbd77b5b0f82f3b8a.tar
guix-patches-36378bd57ec31ba2bbedbdbdbd77b5b0f82f3b8a.tar.gz
gnu: quassel: Enable TLS.
* gnu/packages/patches/quassel-fix-tls-check.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/irc.scm (quassel)[source]: Use it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/irc.scm1
-rw-r--r--gnu/packages/patches/quassel-fix-tls-check.patch25
2 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 011665d387..1d6ac82e5f 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -66,6 +66,7 @@
(method url-fetch)
(uri (string-append "http://quassel-irc.org/pub/quassel-"
version ".tar.bz2"))
+ (patches (search-patches "quassel-fix-tls-check.patch"))
(sha256
(base32
"0ka456fb8ha3w7g74xlzfg6w4azxjjxgrhl4aqpbwg3lnd6fbr4k"))))
diff --git a/gnu/packages/patches/quassel-fix-tls-check.patch b/gnu/packages/patches/quassel-fix-tls-check.patch
new file mode 100644
index 0000000000..057bc02a14
--- /dev/null
+++ b/gnu/packages/patches/quassel-fix-tls-check.patch
@@ -0,0 +1,25 @@
+This allows quasselclient to connect to SSL-enabled quasselcore instances.
+
+The check in qglobal.h requires -fPIC (not -fPIE as it is now). When this check
+fails SSL / TLS is disabled.
+
+This patch comes from the upstream source repository [0] and can be
+removed when the next version is packaged.
+
+[0] https://github.com/quassel/quassel/commit/4768c9e99f99b581d4e32e797db91d0182391696
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -428,6 +428,11 @@ endif()
+ cmake_push_check_state(RESET)
+ set(CMAKE_REQUIRED_INCLUDES ${QT_INCLUDES} ${Qt5Core_INCLUDE_DIRS})
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
++
++if (USE_QT5 AND Qt5_POSITION_INDEPENDENT_CODE)
++ set(CMAKE_REQUIRED_FLAGS "-fPIC -DQT_NO_VERSION_TAGGING")
++endif()
++
+ check_cxx_source_compiles("
+ #include \"qglobal.h\"
+ #if defined QT_NO_SSL
+