summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-08-16 16:35:36 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-01 23:11:20 +0200
commit35f1ebeb2acb06dd920baffc7b3a184b7c45cd15 (patch)
treec1f979733bc38760490a72a9dba5f52ed89f8384 /gnu/packages
parent7c4810a1e543a66bc7aa53f971e70bf1f9d41b08 (diff)
downloadguix-patches-35f1ebeb2acb06dd920baffc7b3a184b7c45cd15.tar
guix-patches-35f1ebeb2acb06dd920baffc7b3a184b7c45cd15.tar.gz
gnu: Add python-mox3.
* gnu/packages/openstack.scm (python-mox3, python2-mox3): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/openstack.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 98619b12f2..48bc716bc5 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -25,6 +25,39 @@
#:select (asl2.0))
#:use-module (guix packages))
+(define-public python-mox3
+ (package
+ (name "python-mox3")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/m/mox3/mox3-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1dwj9lkifdqvrcympqa47bj55l0n0j9jhzv2gj03h0dpzg6mgfkj"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-fixtures" ,python-fixtures)
+ ("python-pbr" ,python-pbr)
+ ("python-setuptools" ,python-setuptools)
+ ("python-six" ,python-six)
+ ("python-testtools" ,python-testtools)))
+ (home-page "http://www.openstack.org/")
+ (synopsis "Mock object framework for Python")
+ (description
+ "Mox3 is an unofficial port of the Google mox framework
+(http://code.google.com/p/pymox/) to Python 3. It was meant to be as compatible
+with mox as possible, but small enhancements have been made. The library was
+tested on Python version 3.2, 2.7 and 2.6.")
+ (license asl2.0)))
+
+(define-public python2-mox3
+ (package-with-python2 python-mox3))
+
(define-public python-pbr
(package
(name "python-pbr")