summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-16 04:20:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-16 11:11:40 +0100
commit340978d7b054dcde6c3334267b40a8293eb0ce85 (patch)
tree173a86b7c1225f74771a1783380689291ed3d955 /gnu/packages
parent10cac630c249dcca0e43e0b3e1cbd28043796eb9 (diff)
downloadguix-patches-340978d7b054dcde6c3334267b40a8293eb0ce85.tar
guix-patches-340978d7b054dcde6c3334267b40a8293eb0ce85.tar.gz
gnu: Use HTTPS for supported nongnu.org home pages.
* gnu/packages/acl.scm (acl)[home-page]: Use HTTPS. * gnu/packages/admin.scm (dmidecode)[home-page]: Likewise. * gnu/packages/attr.scm (attr)[home-page]: Likewise. * gnu/packages/audio.scm (lash)[home-page]: Likewise. * gnu/packages/avr.scm (avr-libc)[home-page]: Likewise. * gnu/packages/backup.scm (rdiff-backup, libchop)[home-page]: Likewise. * gnu/packages/compression.scm (fastjar, lzip, lziprecover, atool) (lunzip, clzip, lzlib, plzip)[home-page]: Likewise. * gnu/packages/emacs.scm (geiser, bbdb, m17n-lib, m17n-lib)[home-page]: Likewise. * gnu/packages/flashing-tools.scm (avrdude)[home-page]: Likewise. * gnu/packages/fontutils.scm (libotf)[home-page]: Likewise. * gnu/packages/game-development.scm (gzochi)[home-page]: Likewise. * gnu/packages/games.scm (enigma)[home-page]: Likewise. * gnu/packages/gsasl.scm (libntlm)[home-page]: Likewise. * gnu/packages/gtk.scm (guile-cairo)[home-page]: Likewise. * gnu/packages/guile.scm (guile-reader, guile-lib, guile-json) (guile-redis, g-wrap)[home-page]: Likewise. * gnu/packages/libunwind.scm (libunwind)[home-page]: Likewise. * gnu/packages/lout.scm (lout)[home-page]: Likewise. * gnu/packages/mpd.scm (sonata)[home-page]: Likewise. * gnu/packages/networking.scm (quagga)[home-page]: Likewise. * gnu/packages/ratpoison.scm (ratpoison)[home-page]: Likewise. * gnu/packages/skribilo.scm (skribilo)[home-page]: Likewise. * gnu/packages/telephony.scm (exosip)[home-page]: Likewise. * gnu/packages/texinfo.scm (texi2html)[home-page]: Likewise. * gnu/packages/xdisorg.scm (xbindkeys)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/acl.scm2
-rw-r--r--gnu/packages/admin.scm2
-rw-r--r--gnu/packages/attr.scm2
-rw-r--r--gnu/packages/audio.scm2
-rw-r--r--gnu/packages/avr.scm2
-rw-r--r--gnu/packages/backup.scm4
-rw-r--r--gnu/packages/compression.scm16
-rw-r--r--gnu/packages/emacs.scm8
-rw-r--r--gnu/packages/flashing-tools.scm2
-rw-r--r--gnu/packages/fontutils.scm2
-rw-r--r--gnu/packages/game-development.scm2
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/gsasl.scm2
-rw-r--r--gnu/packages/gtk.scm2
-rw-r--r--gnu/packages/guile.scm10
-rw-r--r--gnu/packages/libunwind.scm2
-rw-r--r--gnu/packages/lout.scm2
-rw-r--r--gnu/packages/mpd.scm2
-rw-r--r--gnu/packages/networking.scm2
-rw-r--r--gnu/packages/ratpoison.scm2
-rw-r--r--gnu/packages/skribilo.scm2
-rw-r--r--gnu/packages/telephony.scm2
-rw-r--r--gnu/packages/texinfo.scm2
-rw-r--r--gnu/packages/xdisorg.scm2
24 files changed, 39 insertions, 39 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index ae6764993b..31c37a6e7b 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -61,7 +61,7 @@
(native-inputs
`(("gettext" ,gettext-minimal)
("perl" ,perl)))
- (home-page "http://savannah.nongnu.org/projects/acl")
+ (home-page "https://savannah.nongnu.org/projects/acl")
(synopsis
"Library and tools for manipulating access control lists")
(description
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 61ab9654f7..ccf62a6e24 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1183,7 +1183,7 @@ network, which causes enabled computers to power on.")
#:tests? #f ; no 'check' target
#:make-flags (list (string-append "prefix="
(assoc-ref %outputs "out")))))
- (home-page "http://www.nongnu.org/dmidecode/")
+ (home-page "https://www.nongnu.org/dmidecode/")
(synopsis "Read hardware information from the BIOS")
(description
"Dmidecode reports information about your system's hardware as described
diff --git a/gnu/packages/attr.scm b/gnu/packages/attr.scm
index 4dbe09ceca..fe102d211c 100644
--- a/gnu/packages/attr.scm
+++ b/gnu/packages/attr.scm
@@ -71,7 +71,7 @@
(native-inputs
`(("gettext" ,gettext-minimal)))
- (home-page "http://savannah.nongnu.org/projects/attr/")
+ (home-page "https://savannah.nongnu.org/projects/attr/")
(synopsis "Library and tools for manipulating extended attributes")
(description
"Portable library and tools for manipulating extended attributes.")
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index eb11d6cc4e..97fd32ed94 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1591,7 +1591,7 @@ to be plugged into a wide range of audio synthesis and recording packages.")
("libxml2" ,libxml2)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://www.nongnu.org/lash/")
+ (home-page "https://www.nongnu.org/lash/")
(synopsis "Audio application session manager")
(description
"LASH is a session management system for audio applications. It allows
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index e9e93cbb9a..4c7ebf5a8f 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -100,7 +100,7 @@
#t)))))
(native-inputs `(("avr-binutils" ,avr-binutils)
("avr-gcc" ,avr-gcc)))
- (home-page "http://www.nongnu.org/avr-libc/")
+ (home-page "https://www.nongnu.org/avr-libc/")
(synopsis "The AVR C Library")
(description
"AVR Libc is a project whose goal is to provide a high quality C library
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index a494a04047..ca53ffe3e3 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -372,7 +372,7 @@ errors.")
(arguments
`(#:python ,python-2
#:tests? #f))
- (home-page "http://www.nongnu.org/rdiff-backup/")
+ (home-page "https://www.nongnu.org/rdiff-backup/")
(synopsis "Local/remote mirroring+incremental backup")
(description
"Rdiff-backup backs up one directory to another, possibly over a network.
@@ -452,7 +452,7 @@ rsnapshot uses hard links to deduplicate identical files.")
("lzo" ,lzo)
("bzip2" ,bzip2)
("zlib" ,zlib)))
- (home-page "http://nongnu.org/libchop/")
+ (home-page "https://nongnu.org/libchop/")
(synopsis "Tools & library for data backup and distributed storage")
(description
"Libchop is a set of utilities and library for data backup and
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index fc30ab746c..9835735c84 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -153,7 +153,7 @@ the @code{zlib} source.")
"0iginbz2m15hcsa3x4y7v3mhk54gr1r7m3ghx0pg4n46vv2snmpi"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
- (home-page "http://savannah.nongnu.org/projects/fastjar")
+ (home-page "https://savannah.nongnu.org/projects/fastjar")
(synopsis "Replacement for Sun's 'jar' utility")
(description
"FastJar is an attempt to create a much faster replacement for Sun's 'jar'
@@ -475,7 +475,7 @@ some compression ratio).")
(base32
"1p8lvc22sv3damld9ng8y6i8z2dvvpsbi9v7yhr5bc2a20m8iya7"))))
(build-system gnu-build-system)
- (home-page "http://www.nongnu.org/lzip/lzip.html")
+ (home-page "https://www.nongnu.org/lzip/lzip.html")
(synopsis "Lossless data compressor based on the LZMA algorithm")
(description
"Lzip is a lossless data compressor with a user interface similar to the
@@ -496,7 +496,7 @@ archiving. Lzip is a clean implementation of the LZMA algorithm.")
(base32
"0fpnmdxayvd1ff0rk9606dvr431ji6b1v71km4ww244rih1rmmzz"))))
(build-system gnu-build-system)
- (home-page "http://www.nongnu.org/lzip/lziprecover.html")
+ (home-page "https://www.nongnu.org/lzip/lziprecover.html")
(synopsis "Recover and decompress data from damaged lzip files")
(description
"Lziprecover is a data recovery tool and decompressor for files in the lzip
@@ -1890,7 +1890,7 @@ archive can be reverted.")
(inputs
`(("perl" ,perl)
("file" ,file)))
- (home-page "http://www.nongnu.org/atool/")
+ (home-page "https://www.nongnu.org/atool/")
(synopsis "Universal tool to manage file archives of various types")
(description "The main command is @command{aunpack} which extracts files
from an archive. The other commands provided are @command{apack} (to create
@@ -1971,7 +1971,7 @@ algorithms in Java.")
(arguments
`(#:configure-flags
(list "CC=gcc")))
- (home-page "http://www.nongnu.org/lzip/lunzip.html")
+ (home-page "https://www.nongnu.org/lzip/lunzip.html")
(synopsis "Small, stand-alone lzip decompressor")
(description
"Lunzip is a decompressor for files in the lzip compression format (.lz),
@@ -1998,7 +1998,7 @@ Lunzip is intended to be fully compatible with the regular lzip package.")
(arguments
`(#:configure-flags
(list "CC=gcc")))
- (home-page "http://www.nongnu.org/lzip/clzip.html")
+ (home-page "https://www.nongnu.org/lzip/clzip.html")
(synopsis "Small, stand-alone lzip compressor and decompressor")
(description
"Clzip is a compressor and decompressor for files in the lzip compression
@@ -2027,7 +2027,7 @@ Clzip is intended to be fully compatible with the regular lzip package.")
`(#:configure-flags
(list "CC=gcc"
"--enable-shared"))) ; only static (.a) is built by default
- (home-page "http://www.nongnu.org/lzip/lzlib.html")
+ (home-page "https://www.nongnu.org/lzip/lzlib.html")
(synopsis "Lzip data compression C library")
(description
"Lzlib is a C library for in-memory LZMA compression and decompression in
@@ -2051,7 +2051,7 @@ corrupted input.")
(build-system gnu-build-system)
(inputs
`(("lzlib" ,lzlib)))
- (home-page "http://www.nongnu.org/lzip/plzip.html")
+ (home-page "https://www.nongnu.org/lzip/plzip.html")
(synopsis "Parallel lossless data compressor for the lzip format")
(description
"Plzip is a massively parallel (multi-threaded) lossless data compressor
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 0d25ea2b2c..3fd41e1d44 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -334,7 +334,7 @@ editor (without an X toolkit)" )
#t)))))
(inputs `(("guile" ,guile-2.0)))
(native-inputs `(("emacs" ,emacs-minimal)))
- (home-page "http://nongnu.org/geiser/")
+ (home-page "https://nongnu.org/geiser/")
(synopsis "Collection of Emacs modes for Guile and Racket hacking")
(description
"Geiser is a collection of Emacs major and minor modes that conspire with
@@ -1026,7 +1026,7 @@ within a specified width. It is useful for displaying long track titles.")
(symlink "bbdb-loaddefs.el" "bbdb-autoloads.el")))
#t)))))
(native-inputs `(("emacs" ,emacs-minimal)))
- (home-page "http://savannah.nongnu.org/projects/bbdb/")
+ (home-page "https://savannah.nongnu.org/projects/bbdb/")
(synopsis "Contact management utility for Emacs")
(description
"BBDB is the Insidious Big Brother Database for GNU Emacs. It provides
@@ -4632,7 +4632,7 @@ extensibility.")
;; With `guix lint' the home-page URI returns a small page saying
;; that your browser does not handle frames. This triggers the "URI
;; returns suspiciously small file" warning.
- (home-page "http://www.nongnu.org/m17n/")
+ (home-page "https://www.nongnu.org/m17n/")
(synopsis "Multilingual text processing library (database)")
(description "The m17n library realizes multilingualization of
many aspects of applications. The m17n library represents
@@ -4668,7 +4668,7 @@ This package contains the library database.")
;; With `guix lint' the home-page URI returns a small page saying
;; that your browser does not handle frames. This triggers the "URI
;; returns suspiciously small file" warning.
- (home-page "http://www.nongnu.org/m17n/")
+ (home-page "https://www.nongnu.org/m17n/")
(synopsis "Multilingual text processing library (runtime)")
(description "The m17n library realizes multilingualization of
many aspects of applications. The m17n library represents
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 5b79c83a40..5309510d40 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -140,7 +140,7 @@ brick your device.")
(native-inputs
`(("bison" ,bison)
("flex" ,flex)))
- (home-page "http://www.nongnu.org/avrdude/")
+ (home-page "https://www.nongnu.org/avrdude/")
(synopsis "AVR downloader and uploader")
(description
"AVRDUDE is a utility to download/upload/manipulate the ROM and
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 19d5171956..387c4689d8 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -444,7 +444,7 @@ resolution.")
(build-system gnu-build-system)
(propagated-inputs
`(("freetype" ,freetype)))
- (home-page "http://www.nongnu.org/m17n/")
+ (home-page "https://www.nongnu.org/m17n/")
(synopsis "Library for handling OpenType Font")
(description "This library can read Open Type Layout Tables from an OTF
file. Currently these tables are supported; head, name, cmap, GDEF, GSUB, and
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a276be692b..5da40b1ae2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -240,7 +240,7 @@ PCM data.")
("ncurses" ,ncurses)
("sdl" ,sdl)
("zlib" ,zlib)))
- (home-page "http://www.nongnu.org/gzochi/")
+ (home-page "https://www.nongnu.org/gzochi/")
(synopsis "Scalable middleware for multiplayer games")
(description
"gzochi is a framework for developing massively multiplayer online games.
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 286d0feef2..5004e72161 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4725,7 +4725,7 @@ The Flag. You can even design your own maps!")
(native-inputs
`(("pkg-config" ,pkg-config)
("imagemagick" ,imagemagick)))
- (home-page "http://www.nongnu.org/enigma")
+ (home-page "https://www.nongnu.org/enigma")
(synopsis "Puzzle game with a dexterity component")
(description "Enigma is a puzzle game with 550 unique levels. The object
of the game is to find and uncover pairs of identically colored ‘Oxyd’ stones.
diff --git a/gnu/packages/gsasl.scm b/gnu/packages/gsasl.scm
index 727d0f0d52..8b15a7ce09 100644
--- a/gnu/packages/gsasl.scm
+++ b/gnu/packages/gsasl.scm
@@ -45,7 +45,7 @@
(description
"Libntlm is a library that implements NTLM authentication.")
(license license:lgpl2.1+)
- (home-page "http://www.nongnu.org/libntlm/")))
+ (home-page "https://www.nongnu.org/libntlm/")))
(define-public gss
(package
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c66a3e5a17..86dff08e40 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -803,7 +803,7 @@ application suites.")
`(("cairo" ,cairo)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://www.nongnu.org/guile-cairo/")
+ (home-page "https://www.nongnu.org/guile-cairo/")
(synopsis "Cairo bindings for GNU Guile")
(description
"Guile-Cairo wraps the Cairo graphics library for Guile Scheme.
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 7c03a9c86b..9005779826 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -528,7 +528,7 @@ document syntax.
Guile-Reader’s approach is similar to Common Lisp’s “read table”, but
hopefully more powerful and flexible (for instance, one may instantiate as
many readers as needed).")
- (home-page "http://www.nongnu.org/guile-reader/")
+ (home-page "https://www.nongnu.org/guile-reader/")
(license license:gpl3+)))
(define-public guile2.0-reader
@@ -739,7 +739,7 @@ $(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
#t)))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("guile" ,guile-2.2)))
- (home-page "http://www.nongnu.org/guile-lib/")
+ (home-page "https://www.nongnu.org/guile-lib/")
(synopsis "Collection of useful Guile Scheme modules")
(description
"Guile-Lib is intended as an accumulation place for pure-scheme Guile
@@ -782,7 +782,7 @@ for Guile\".")
(string-append all "/@GUILE_EFFECTIVE_VERSION@")))))))
(build-system gnu-build-system)
(native-inputs `(("guile" ,guile-2.2)))
- (home-page "http://savannah.nongnu.org/projects/guile-json/")
+ (home-page "https://savannah.nongnu.org/projects/guile-json/")
(synopsis "JSON module for Guile")
(description
"Guile-JSON supports parsing and building JSON documents according to the
@@ -1290,7 +1290,7 @@ above command-line parameters.")
(build-system gnu-build-system)
(native-inputs
`(("guile" ,guile-2.0)))
- (home-page "http://savannah.nongnu.org/projects/guile-redis/")
+ (home-page "https://savannah.nongnu.org/projects/guile-redis/")
(synopsis "Redis client library for Guile")
(description "Guile-redis provides a Scheme interface to the Redis
key-value cache and store.")
@@ -1460,7 +1460,7 @@ wrappers for inter-language calls. It currently only supports generating Guile
wrappers for C functions. Given a definition of the types and prototypes for
a given C interface, G-Wrap will automatically generate the C code that
provides access to that interface and its types from the Scheme level.")
- (home-page "http://www.nongnu.org/g-wrap/index.html")
+ (home-page "https://www.nongnu.org/g-wrap/index.html")
(license license:lgpl2.1+)))
(define-public guile-dbi
diff --git a/gnu/packages/libunwind.scm b/gnu/packages/libunwind.scm
index e747d37787..578154f70d 100644
--- a/gnu/packages/libunwind.scm
+++ b/gnu/packages/libunwind.scm
@@ -41,7 +41,7 @@
;; expected to fail).
;; Report them upstream.
'(#:tests? #f))
- (home-page "http://www.nongnu.org/libunwind")
+ (home-page "https://www.nongnu.org/libunwind")
(synopsis "Determining the call chain of a program")
(description
"The primary goal of this project is to define a portable and efficient C
diff --git a/gnu/packages/lout.scm b/gnu/packages/lout.scm
index f2c724ae07..1a1d0b3274 100644
--- a/gnu/packages/lout.scm
+++ b/gnu/packages/lout.scm
@@ -124,4 +124,4 @@ TeX macros because Lout is a high-level, purely functional language, the
outcome of an eight-year research project that went back to the
beginning.")
(license gpl3+)
- (home-page "http://savannah.nongnu.org/projects/lout/"))))
+ (home-page "https://savannah.nongnu.org/projects/lout/"))))
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 82681aa68a..ac1fe51f15 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -332,5 +332,5 @@ interface for the Music Player Daemon.")
(description "Sonata is an elegant graphical client for the Music Player
Daemon (MPD). It supports playlists, multiple profiles (connecting to different
MPD servers, search and multimedia key support.")
- (home-page "http://www.nongnu.org/sonata/")
+ (home-page "https://www.nongnu.org/sonata/")
(license license:gpl3+)))
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 69da2e21ab..1e03678572 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1427,7 +1427,7 @@ acts as an abstraction layer to the underlying Unix kernel and presents the
Zserv API over a Unix or TCP stream to Quagga clients. It is these Zserv
clients which typically implement a routing protocol and communicate routing
updates to the zebra daemon.")
- (home-page "http://www.nongnu.org/quagga/")
+ (home-page "https://www.nongnu.org/quagga/")
(license license:gpl2+)))
(define-public thc-ipv6
diff --git a/gnu/packages/ratpoison.scm b/gnu/packages/ratpoison.scm
index e68b345b06..d630c24fd4 100644
--- a/gnu/packages/ratpoison.scm
+++ b/gnu/packages/ratpoison.scm
@@ -82,7 +82,7 @@
`(("perl",perl)
("pkg-config" ,pkg-config)
("ratpoison.desktop" ,ratpoison.desktop)))
- (home-page "http://www.nongnu.org/ratpoison/")
+ (home-page "https://www.nongnu.org/ratpoison/")
(synopsis "Simple mouse-free tiling window manager")
(description
"Ratpoison is a simple window manager with no fat library
diff --git a/gnu/packages/skribilo.scm b/gnu/packages/skribilo.scm
index 87dc3558de..f10acaec70 100644
--- a/gnu/packages/skribilo.scm
+++ b/gnu/packages/skribilo.scm
@@ -77,7 +77,7 @@
(propagated-inputs `(("guile-reader" ,guile2.0-reader)
("guile-lib" ,guile2.0-lib)))
- (home-page "http://www.nongnu.org/skribilo/")
+ (home-page "https://www.nongnu.org/skribilo/")
(synopsis "Document production tool written in Guile Scheme")
(description
"Skribilo is a free document production tool that takes a structured
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 53bc9f950b..018de0c6ce 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -162,7 +162,7 @@ multiplayer games.")
(license license:gpl2+)
;; (plus OpenSSL linking exception)
;; http://git.savannah.gnu.org/cgit/exosip.git/plain/LICENSE.OpenSSL
- (home-page "http://savannah.nongnu.org/projects/exosip")))
+ (home-page "https://savannah.nongnu.org/projects/exosip")))
(define-public sipwitch
(package
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 8c33023bd0..7b9121bf80 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -165,7 +165,7 @@ is on expressing the content semantically, avoiding physical markup commands.")
;; texi2html.pl to avoid the warnings seems non-trivial, so we simply
;; disable the tests.
'(#:tests? #f))
- (home-page "http://www.nongnu.org/texi2html/")
+ (home-page "https://www.nongnu.org/texi2html/")
(synopsis "Convert Texinfo to HTML")
(description
"Texi2HTML is a Perl script which converts Texinfo source files to HTML
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c81e5ad01f..70a987b05b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -722,7 +722,7 @@ transparent text on your screen.")
(inputs
`(("libx11" ,libx11)
("guile" ,guile-2.0)))
- (home-page "http://www.nongnu.org/xbindkeys/")
+ (home-page "https://www.nongnu.org/xbindkeys/")
(synopsis "Associate a combination of keys with a shell command")
(description
"XBindKeys is a program that allows you to launch shell commands with