summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 04:28:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 04:44:34 +0200
commit30714da09a50bf20780e9903104e29c930da855a (patch)
tree854cea9aee7e54d660f65a82f64024b646f56c3e /gnu/packages
parent7b88396febe35e05bb4f67ed609204c8533314d8 (diff)
downloadguix-patches-30714da09a50bf20780e9903104e29c930da855a.tar
guix-patches-30714da09a50bf20780e9903104e29c930da855a.tar.gz
gnu: wgetpaste: Update bpaste URL & regular expressions.
* gnu/packages/wget.scm (wgetpaste)[source]: Add patch. * gnu/packages/patches/wgetpaste-update-bpaste.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/wgetpaste-update-bpaste.patch27
-rw-r--r--gnu/packages/wget.scm3
2 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/patches/wgetpaste-update-bpaste.patch b/gnu/packages/patches/wgetpaste-update-bpaste.patch
new file mode 100644
index 0000000000..f92a0c17ed
--- /dev/null
+++ b/gnu/packages/patches/wgetpaste-update-bpaste.patch
@@ -0,0 +1,27 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Tue, 01 Sep 2020 04:23:25 +0200
+Subject: [PATCH] Update bpaste URL & regular expressions.
+
+diff -Naur wgetpaste-2.30/wgetpaste wgetpaste-2.30a/wgetpaste
+--- wgetpaste-2.30/wgetpaste 2020-07-31 23:56:05.000000000 +0200
++++ wgetpaste-2.30a/wgetpaste 2020-09-01 04:22:37.499898403 +0200
+@@ -16,7 +16,7 @@
+ SERVICES="codepad bpaste dpaste gists snippets"
+ # bpaste
+ ENGINE_bpaste=pinnwand
+-URL_bpaste="https://bpaste.net/"
++URL_bpaste="https://bpa.st/"
+ DEFAULT_EXPIRATION_bpaste="1week"
+ DEFAULT_LANGUAGE_bpaste="text"
+ # codepad
+@@ -194,8 +194,8 @@
+ xml+velocity xml xquery xslt xtend yaml"
+ EXPIRATIONS_pinnwand="1day 1week 1month never"
+ POST_pinnwand="submit=Paste! % % lexer expiry % code"
+-REGEX_LOC_pinnwand="\(/show/[^ ]*\).*$|https://bpaste.net\1"
+-REGEX_RAW_pinnwand='s|^\(https\?://[^/]*/\)show\(/[^ ]*/\?\)$|\1raw\2|'
++REGEX_LOC_pinnwand="\(/[^ ]*\).*$|https://bpa.st\1"
++REGEX_RAW_pinnwand='s|^\(https\?://[^/]*\)\(/[^ ]*/\?\)$|\1/raw\2|'
+
+ ### errors
+ die() {
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index a8345da818..7950b3b729 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -83,7 +83,8 @@ in downloaded documents to relative links.")
(uri (string-append "https://wgetpaste.zlin.dk/wgetpaste-"
version ".tar.bz2"))
(sha256
- (base32 "14k5i6j6f34hcf9gdb9cnvfwscn0ys2dgd73ci421wj9zzqkbv73"))))
+ (base32 "14k5i6j6f34hcf9gdb9cnvfwscn0ys2dgd73ci421wj9zzqkbv73"))
+ (patches (search-patches "wgetpaste-update-bpaste.patch"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)