summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-13 12:49:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-13 12:51:25 -0400
commit2e6be59131e9f16cbb690aaaffc0b2470dead611 (patch)
tree9757944efc8de7fe480128be42921b6055d8cbad /gnu/packages
parent6ed5b496bc1a2199fe5d40b5186df38789ff6937 (diff)
downloadguix-patches-2e6be59131e9f16cbb690aaaffc0b2470dead611.tar
guix-patches-2e6be59131e9f16cbb690aaaffc0b2470dead611.tar.gz
gnu: mapnik: Update to 3.1.0.
The build still fails, but hopefully it gets us closer. * gnu/packages/geo.scm (mapnik): Update to 3.1.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c934ee9e27..024a9dd883 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -839,7 +839,7 @@ street bearings/orientations, and speed/travel time.")
(define-public mapnik
(package
(name "mapnik")
- (version "3.0.18")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
@@ -847,7 +847,7 @@ street bearings/orientations, and speed/travel time.")
version "/mapnik-v" version ".tar.bz2"))
(sha256
(base32
- "06frcikaj2mgz3abfk5h0z4j3hbksi0zikwjngbjv4p5f3pwxf8q"))))
+ "0qb2irykja5qhr9apz9r230pcxap9v3j85fi98mj2xd9sa163ms3"))))
(build-system scons-build-system)
(inputs
(list boost
@@ -864,10 +864,9 @@ street bearings/orientations, and speed/travel time.")
sqlite
zlib))
(native-inputs
- (list pkg-config))
+ (list pkg-config postgresql))
(arguments
- `(#:scons ,scons-python2
- #:scons-flags
+ `(#:scons-flags
(list "CC=gcc"
(string-append "PREFIX=" %output)
(string-append "CUSTOM_LDFLAGS=-Wl,-rpath=" %output "/lib"))))