summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-06 16:45:22 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-06 18:14:52 +0200
commit2aa0bada76dc664e9e38f4206ec526fd278a6114 (patch)
tree3ac3cb794192be1a769360fe01b81f8f037d05a0 /gnu/packages
parentb2c108ff3346531f63968f0501ef3fdbe2ea8d1e (diff)
downloadguix-patches-2aa0bada76dc664e9e38f4206ec526fd278a6114.tar
guix-patches-2aa0bada76dc664e9e38f4206ec526fd278a6114.tar.gz
gnu: Add ghc-aeson-pretty.
* gnu/packages/haskell.scm (ghc-aeson-pretty): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c3e0a6100b..738c3a18c0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4856,6 +4857,39 @@ for Haskell, optimized for ease of use and high performance. (A note on
naming: in Greek mythology, Aeson was the father of Jason.)")
(license license:bsd-3)))
+(define-public ghc-aeson-pretty
+ (package
+ (name "ghc-aeson-pretty")
+ (version "0.7.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/aeson-pretty/aeson-pretty-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "03ap81853qi8yd9kdgczllrrni23a6glsfxrwj8zab6ipjrbh234"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers"
+ ,ghc-unordered-containers)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-cmdargs" ,ghc-cmdargs)))
+ (home-page "http://github.com/informatikr/aeson-pretty")
+ (synopsis "JSON pretty-printing library and command-line tool")
+ (description
+ "This package provides a JSON pretty-printing library compatible with aeson
+as well as a command-line tool to improve readabilty of streams of JSON data.
+The library provides the function @code{encodePretty}. It is a drop-in
+replacement for aeson's @code{encode} function, producing JSON-ByteStrings for
+human readers. The command-line tool reads JSON from stdin and writes
+prettified JSON to stdout. It also offers a complementary \"compact\"-mode,
+essentially the opposite of pretty-printing.")
+ (license license:bsd-3)))
+
(define-public ghc-wai
(package
(name "ghc-wai")