summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-10-05 20:43:32 -0500
committerMarius Bakke <marius@gnu.org>2020-10-13 23:36:44 +0200
commit23a97f52405b49309bf8825099d8c66a9ad9998d (patch)
treee50c39789bd64a6015779b5e174171477418cc3b /gnu/packages
parent6b219b899217d635e5f20e212a88393caff83cd8 (diff)
downloadguix-patches-23a97f52405b49309bf8825099d8c66a9ad9998d.tar
guix-patches-23a97f52405b49309bf8825099d8c66a9ad9998d.tar.gz
gnu: Add python-dictdiffer.
* gnu/packages/python-xyz.scm (python-dictdiffer): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 402007d0c2..f5c58609f5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -85,6 +85,7 @@
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
+;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21472,6 +21473,37 @@ randomness (including real life dice) and different wordlists (including
cryptographically signed ones).")
(license license:gpl3+)))
+(define-public python-dictdiffer
+ (package
+ (name "python-dictdiffer")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "dictdiffer" version))
+ (sha256
+ (base32
+ "1lk3qmy1hkaphk4n7ayfk0wl6m2yvd6r7qkam6yncqfzgkbc1phs"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-check-manifest" ,python-check-manifest)
+ ("python-coverage" ,python-coverage)
+ ("python-isort" ,python-isort)
+ ("python-mock" ,python-mock)
+ ("python-pydoctstyle" ,python-pydocstyle)
+ ("python-pytest-cache" ,python-pytest-cache)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-pep8" ,python-pytest-pep8)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-tox" ,python-tox)))
+ (home-page "https://github.com/inveniosoftware/dictdiffer")
+ (synopsis "Diff and patch Python dictionary objects")
+ (description
+ "Dictdiffer is a Python module that helps you to diff and patch
+dictionaries.")
+ (license license:expat)))
+
(define-public pyzo
(package
(name "pyzo")