summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-07 04:05:02 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-26 12:59:34 +0100
commit22ee7209797c023b95e22ced156df62cbff90184 (patch)
tree64cefa77742e7681c465d29c964cd6df3c84ed62 /gnu/packages
parent1a9b3faaf25c40552e100f4a00bef8f0a32ba1dc (diff)
downloadguix-patches-22ee7209797c023b95e22ced156df62cbff90184.tar
guix-patches-22ee7209797c023b95e22ced156df62cbff90184.tar.gz
gnu: pciutils: Build fixes for the Hurd.
* gnu/packages/linux.scm (kmod)[supported-systems]: Remove the Hurd. * gnu/packages/patches/pciutils-hurd-configure.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/pciutils.scm (pciutils): Use it. [inputs]: Include kmod only for supported systems.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm1
-rw-r--r--gnu/packages/patches/pciutils-hurd-configure.patch35
-rw-r--r--gnu/packages/pciutils.scm10
3 files changed, 45 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b73b86b0e8..3abfc469ba 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2784,6 +2784,7 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
'("insmod" "rmmod" "lsmod" "modprobe"
"modinfo" "depmod"))
#t))))))
+ (supported-systems (delete "i586-gnu" %supported-systems))
(home-page "https://www.kernel.org/")
(synopsis "Kernel module tools")
(description "Kmod is a set of tools to handle common tasks with Linux
diff --git a/gnu/packages/patches/pciutils-hurd-configure.patch b/gnu/packages/patches/pciutils-hurd-configure.patch
new file mode 100644
index 0000000000..226891a995
--- /dev/null
+++ b/gnu/packages/patches/pciutils-hurd-configure.patch
@@ -0,0 +1,35 @@
+Add ability to detect GNU/Hurd when configuring.
+
+Adapted from https://git.hadrons.org/cgit/debian/pkgs/pciutils.git/tree/debian/patches/00-configure-hurd.patch
+
+From e39a3af22501234a91cf28e8c57b45f9379f9101 Mon Sep 17 00:00:00 2001
+From: Damien Zammit <damien@zamaudio.com>
+Date: Fri, 26 Oct 2018 09:24:04 -0400
+Subject: [PATCH 2/2] Add ability to detect GNU/Hurd when configuring
+
+---
+ lib/configure | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+--- a/lib/configure
++++ b/lib/configure
+@@ -25,7 +25,7 @@ if [ -z "$HOST" ] ; then
+ proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
+ cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
+ else
+- cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
++ cpu=`uname -m | sed 's/^i.86-AT386/i386/;s/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
+ fi
+ if [ "$sys" = "DragonFly" ]
+ then
+@@ -39,6 +39,10 @@ if [ -z "$HOST" ] ; then
+ then
+ sys=cygwin
+ fi
++ if [ "$sys" = "GNU" ]
++ then
++ sys=gnu
++ fi
+ HOST=${3:-$cpu-$sys}
+ fi
+ [ -n "$RELEASE" ] && rel="${RELEASE}"
diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index 0a55299c93..c992988437 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,8 +26,10 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages hurd)
#:use-module (gnu packages linux)
#:use-module (gnu packages base))
@@ -39,6 +42,7 @@
(uri (string-append
"mirror://kernel.org/software/utils/pciutils/pciutils-"
version ".tar.xz"))
+ (patches (search-patches "pciutils-hurd-configure.patch"))
(sha256
(base32
"0mb0f2phdcmp4kfiqsszn2k6nlln0w160ffzrjjv4bbfjwrgfzzn"))))
@@ -100,7 +104,11 @@
`(("which" ,which)
("pkg-config" ,pkg-config)))
(inputs
- `(("kmod" ,kmod)
+ `(,@(if (member (or (%current-target-system)
+ (%current-system))
+ (package-supported-systems kmod))
+ `(("kmod" ,kmod))
+ '())
("zlib" ,zlib)))
(home-page "https://mj.ucw.cz/sw/pciutils/")
(synopsis "Programs for inspecting and manipulating PCI devices")