summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-03 09:43:49 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-16 20:08:30 +0100
commit22074259d2f9550267c65102a348b0efd1f31d88 (patch)
tree5ffc1701e89e385835e24e5c9225e547b6c37aa8 /gnu/packages
parent7cca1fd4007277eb7c2cc7a0f8df76bfd381e05d (diff)
downloadguix-patches-22074259d2f9550267c65102a348b0efd1f31d88.tar
guix-patches-22074259d2f9550267c65102a348b0efd1f31d88.tar.gz
gnu: Add ocaml-base.
* gnu/packages/ocaml.scm (ocaml-base): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a44cfa0c37..7f54553ed7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4963,3 +4963,42 @@ parsexp_io.")
"This package is part of Jane Street's Core library. Sexplib contains
functionality for parsing and pretty-printing s-expressions.")
(license license:expat)))
+
+(define-public ocaml-base
+ (package
+ (name "ocaml-base")
+ (version "0.11.1")
+ (home-page "https://github.com/janestreet/base")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0j6xb4265jr41vw4fjzak6yr8s30qrnzapnc6rl1dxy8bjai0nir"))))
+ (build-system dune-build-system)
+ (inputs
+ `(("ocaml-sexplib0" ,ocaml-sexplib0)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ ;; make warnings non fatal (jbuilder behaviour)
+ (lambda _
+ (invoke "dune" "build" "@install" "--profile=release"))))))
+ (synopsis
+ "Full standard library replacement for OCaml")
+ (description
+ "Base is a complete and portable alternative to the OCaml standard
+library. It provides all standard functionalities one would expect
+from a language standard library. It uses consistent conventions
+across all of its module.
+
+Base aims to be usable in any context. As a result system dependent
+features such as I/O are not offered by Base. They are instead
+provided by companion libraries such as
+@url{https://github.com/janestreet/stdio, ocaml-stdio}.")
+ (license license:expat)))