summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-07-01 11:02:02 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-07-01 11:02:02 +0200
commit1ac4959c6a94a89fc8d3a73239d107cfb1d96240 (patch)
tree5bdc03bf1564cf1eee3aee892f46005fb126e325 /gnu/packages
parent8ed5d9502dffe6884978fab32398f9c68e38a6c8 (diff)
downloadguix-patches-1ac4959c6a94a89fc8d3a73239d107cfb1d96240.tar
guix-patches-1ac4959c6a94a89fc8d3a73239d107cfb1d96240.tar.gz
gnu: sbcl: Update to 2.0.6.
* gnu/packages/lisp.scm (sbcl): Update to 2.0.6.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a2e0f0724d..8227765dd4 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -372,14 +372,14 @@ an interpreter, a compiler, a debugger, and much more.")
(define-public sbcl
(package
(name "sbcl")
- (version "2.0.5")
+ (version "2.0.6")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
version "-source.tar.bz2"))
(sha256
- (base32 "1jz26w1i3riv032aa35vww4cv7cjk2ww7dp70c7wk4r8s66zhl00"))))
+ (base32 "1bnxmmq2yvwj6hb4d96v3k82bcmwhfqx5jixzr14zk4p3m6dd4px"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(native-inputs
@@ -397,12 +397,13 @@ an interpreter, a compiler, a debugger, and much more.")
;; ABCL and ECL (as well as CCL, CMUCL, CLISP and SBCL itself)
;;
;; CCL is not bootstrappable so it won't do. CLISP 2.49 seems to work.
- ;; ECL too. ECL builds SBCL about 20% slower than CLISP. As of
- ;; 2019-09-05, ECL was last updated in 2020 while CLISP was last updated
- ;; in 2010.
+ ;; ECL too. As of 2020-07-01, ECL was last updated in 2020 while CLISP
+ ;; was last updated in 2010, and both take about the same time to build SBCL.
;;
- ;; For now we stick to CLISP for all systems. We keep the `match' here to
- ;; make it easier to change the host compiler for various architectures.
+ ;; For now we stick to CLISP for all systems. We keep the `match' here
+ ;; to make it easier to change the host compiler for various
+ ;; architectures. Consider switching to ECL if it gets faster than CLISP
+ ;; (maybe post 2020 release).
`(,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
`(("clisp" ,clisp)))