summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-12-01 10:47:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-12-01 10:47:29 +0200
commit161fb9be8edf37cf52c3d223214d81e4cbb7a787 (patch)
tree66a26b27eaab243c03525349bbdc5159489a4807 /gnu/packages
parent4181c9393d46bb8e24af1970c0e2adbcbfb2c639 (diff)
downloadguix-patches-161fb9be8edf37cf52c3d223214d81e4cbb7a787.tar
guix-patches-161fb9be8edf37cf52c3d223214d81e4cbb7a787.tar.gz
gnu: nasm: Switch patch to phase.
* gnu/packages/assembly.scm (nasm)[source]: Remove patch. [arguments]: Disable ps and pdf doc outputs in new phase. * gnu/packages/patches/nasm-no-ps-pdf.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/assembly.scm20
-rw-r--r--gnu/packages/patches/nasm-no-ps-pdf.patch20
2 files changed, 14 insertions, 26 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index a6e4abb70e..dd675ed019 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -41,17 +41,25 @@
version "/" name "-" version ".tar.xz"))
(sha256
(base32
- "12bl6vc5sjp9nnhf0iwy6l27vq783y0rxrjpp8sy84h5cb7a3fwx"))
- (patches (search-patches "nasm-no-ps-pdf.patch"))))
+ "12bl6vc5sjp9nnhf0iwy6l27vq783y0rxrjpp8sy84h5cb7a3fwx"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl) ;for doc and test target
("texinfo" ,texinfo)))
(arguments
`(#:test-target "test"
- #:phases (modify-phases %standard-phases
- (add-after 'install 'install-info
- (lambda _
- (zero? (system* "make" "install_doc")))))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'dont-build-ps-pdf-outputs
+ (lambda _
+ (substitute* "doc/Makefile.in"
+ (("info html nasmdoc.txt nasmdoc.ps nasmdoc.pdf")
+ "info html nasmdoc.txt")
+ (("nasmdoc.ps nasmdoc.pdf nasmdoc.txt \\$\\(INSTALLROOT\\)\\$\\(docdir\\)")
+ "nasmdoc.txt $(INSTALLROOT)$(docdir)"))
+ #t))
+ (add-after 'install 'install-info
+ (lambda _
+ (zero? (system* "make" "install_doc")))))))
(home-page "http://www.nasm.us/")
(synopsis "80x86 and x86-64 assembler")
(description
diff --git a/gnu/packages/patches/nasm-no-ps-pdf.patch b/gnu/packages/patches/nasm-no-ps-pdf.patch
deleted file mode 100644
index b03b57a6ed..0000000000
--- a/gnu/packages/patches/nasm-no-ps-pdf.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Avoid building PS and PDF docs, which do not build bit-reproducible. NASM
-already installs doc in info and html.
-
---- nasm-2.12.01/doc/Makefile.in.orig 2016-06-21 18:02:59.483484829 +0200
-+++ nasm-2.12.01/doc/Makefile.in 2016-06-21 18:03:46.700151410 +0200
-@@ -27,7 +27,7 @@
- PS2PDF = @PS2PDF@ # Part of GhostScript
-
- SRCS = nasmdoc.src inslist.src changes.src
--OUT = info html nasmdoc.txt nasmdoc.ps nasmdoc.pdf
-+OUT = info html nasmdoc.txt
-
- # exports
- export srcdir
-@@ -100,4 +100,4 @@
- $(INSTALL_DATA) info/* $(INSTALLROOT)$(infodir)
- mkdir -p $(INSTALLROOT)$(docdir)/html
- $(INSTALL_DATA) html/* $(INSTALLROOT)$(docdir)/html
-- $(INSTALL_DATA) nasmdoc.ps nasmdoc.pdf nasmdoc.txt $(INSTALLROOT)$(docdir)
-+ $(INSTALL_DATA) nasmdoc.txt $(INSTALLROOT)$(docdir)