summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-10-20 16:47:58 -0500
committerEric Bavier <bavier@member.fsf.org>2014-10-20 16:49:32 -0500
commit1454a2ba88fc0696192e520e2cbd27b380e4d8f2 (patch)
tree0e06f353b6acec63c2309e8d447cfd41d93a74a8 /gnu/packages
parent7947a05439cc26d93bd93300f38d216dbb93c76d (diff)
downloadguix-patches-1454a2ba88fc0696192e520e2cbd27b380e4d8f2.tar
guix-patches-1454a2ba88fc0696192e520e2cbd27b380e4d8f2.tar.gz
gnu: ccache: Upgrade to 3.1.10.
* gnu/packages/ccache.scm (ccache): Upgrade to 3.1.10. [source]: Remove patches. * gnu/packages/patches/ccache-stdc-predef-test.patch: Delete patch. * gnu-system.am (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ccache.scm5
-rw-r--r--gnu/packages/patches/ccache-stdc-predef-test.patch157
2 files changed, 2 insertions, 160 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 4918ec9609..2b45ab09d6 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -28,7 +28,7 @@
(define-public ccache
(package
(name "ccache")
- (version "3.1.9")
+ (version "3.1.10")
(source
(origin
(method url-fetch)
@@ -36,8 +36,7 @@
version ".tar.xz"))
(sha256
(base32
- "1i06015jjc0n55xgvhv2h37fjp0i7z8a10s0v40f87c5mprzv0a9"))
- (patches (list (search-patch "ccache-stdc-predef-test.patch")))))
+ "0mr8n1nbykxw4rs55ad8wd6xmfhihn09mxpxb91sn9mlsd1ryhw8"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl))) ;for test.sh
(inputs `(("zlib" ,zlib)))
diff --git a/gnu/packages/patches/ccache-stdc-predef-test.patch b/gnu/packages/patches/ccache-stdc-predef-test.patch
deleted file mode 100644
index bd9444c2df..0000000000
--- a/gnu/packages/patches/ccache-stdc-predef-test.patch
+++ /dev/null
@@ -1,157 +0,0 @@
-This patch is a combination of the following commits::
-
- https://git.samba.org/?p=ccache.git;a=commit;h=b5d63f81c1a83fd4c50b769a96a04f581b7db70c
- https://git.samba.org/?p=ccache.git;a=commit;h=a11f5688748ecb49f590b3f4bc0e9b3458f9a56f
- https://git.samba.org/?p=ccache.git;a=commit;h=5a9322c56ed0cd16255966e99077843aae57ab3e
-
-from the general discussion at
-http://comments.gmane.org/gmane.comp.compilers.ccache/1089
-
---- a/test.sh
-+++ b/test.sh
-@@ -562,6 +562,12 @@
- EOF
- backdate test1.h test2.h test3.h
-
-+ $COMPILER -c -Wp,-MD,expected.d test.c
-+ expected_d_content=`cat expected.d`
-+
-+ $COMPILER -c -Wp,-MMD,expected_mmd.d test.c
-+ expected_mmd_d_content=`cat expected_mmd.d`
-+
- ##################################################################
- # First compilation is a miss.
- testname="first compilation"
-@@ -677,7 +683,7 @@
- checkstat 'cache hit (direct)' 0
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_d_content"
-
- rm -f other.d
-
-@@ -685,7 +691,7 @@
- checkstat 'cache hit (direct)' 1
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_d_content"
-
- rm -f other.d
-
-@@ -698,7 +704,7 @@
- checkstat 'cache hit (direct)' 0
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_mmd_d_content"
-
- rm -f other.d
-
-@@ -706,7 +712,7 @@
- checkstat 'cache hit (direct)' 1
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_mmd_d_content"
-
- rm -f other.d
-
-@@ -760,7 +766,7 @@
- checkstat 'cache hit (direct)' 0
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile test.d "$expected_d_content"
-
- rm -f test.d
-
-@@ -768,7 +774,7 @@
- checkstat 'cache hit (direct)' 1
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile test.d "$expected_d_content"
-
- ##################################################################
- # Check the scenario of running a ccache with direct mode on a cache
-@@ -780,7 +786,7 @@
- checkstat 'cache hit (direct)' 0
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile test.d "$expected_d_content"
-
- rm -f test.d
-
-@@ -788,7 +794,7 @@
- checkstat 'cache hit (direct)' 0
- checkstat 'cache hit (preprocessed)' 1
- checkstat 'cache miss' 1
-- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile test.d "$expected_d_content"
-
- rm -f test.d
-
-@@ -796,7 +802,7 @@
- checkstat 'cache hit (direct)' 0
- checkstat 'cache hit (preprocessed)' 2
- checkstat 'cache miss' 1
-- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile test.d "$expected_d_content"
-
- rm -f test.d
-
-@@ -804,7 +810,7 @@
- checkstat 'cache hit (direct)' 1
- checkstat 'cache hit (preprocessed)' 2
- checkstat 'cache miss' 1
-- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile test.d "$expected_d_content"
-
- ##################################################################
- # Check that -MF works.
-@@ -815,7 +821,7 @@
- checkstat 'cache hit (direct)' 0
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_d_content"
-
- rm -f other.d
-
-@@ -823,7 +829,7 @@
- checkstat 'cache hit (direct)' 1
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_d_content"
-
- ##################################################################
- # Check that a missing .d file in the cache is handled correctly.
-@@ -835,13 +841,13 @@
- checkstat 'cache hit (direct)' 0
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_d_content"
-
- $CCACHE $COMPILER -c -MD test.c
- checkstat 'cache hit (direct)' 1
- checkstat 'cache hit (preprocessed)' 0
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_d_content"
-
- find $CCACHE_DIR -name '*.d' -exec rm -f '{}' \;
-
-@@ -849,7 +855,7 @@
- checkstat 'cache hit (direct)' 1
- checkstat 'cache hit (preprocessed)' 1
- checkstat 'cache miss' 1
-- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
-+ checkfile other.d "$expected_d_content"
-
- ##################################################################
- # Check that stderr from both the preprocessor and the compiler is emitted