summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-04-16 12:50:57 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-05-17 00:24:02 +0200
commit13b1319092e8a7100c346308a7a012a58c254c5f (patch)
treed4fec523cac937709cc4ccdfbf70419d7ca6d9a0 /gnu/packages
parent938ffcbb0589adc07dc12c79eda3e1e2bb9e7cf8 (diff)
downloadguix-patches-13b1319092e8a7100c346308a7a012a58c254c5f.tar
guix-patches-13b1319092e8a7100c346308a7a012a58c254c5f.tar.gz
gnu: tsukundere: Update to 0.3.0.
* gnu/packages/game-development.scm (tsukundere): Update to 0.3.0. [patch-command]: Patch path to guile. Construct load paths directly from inputs. [propagated-inputs]: Remove. [inputs]: Add guile and guile-sdl2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm52
1 files changed, 33 insertions, 19 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index cee7e5dc0a..52541196b3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -493,7 +493,7 @@ clone.")
(define-public tsukundere
(package
(name "tsukundere")
- (version "0.2.3")
+ (version "0.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -502,10 +502,12 @@ clone.")
(file-name (git-file-name name version))
(sha256
(base32
- "05ckds2df810441wfavllx9lsw5jsc9h3nb7m31df01nsj56azdw"))))
+ "06jiaylbnx8khicsaq2gwnd8wspjhjymbb5z6x5445krklk0jx18"))))
(build-system gnu-build-system)
(arguments
- `(#:modules (((guix build guile-build-system)
+ `(#:modules ((ice-9 match)
+ (srfi srfi-1)
+ ((guix build guile-build-system)
#:select (target-guile-effective-version))
,@%gnu-build-system-modules)
#:imported-modules ((guix build guile-build-system)
@@ -513,22 +515,33 @@ clone.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-command
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (version (target-guile-effective-version))
- (scm (string-append out "/share/guile/site/"
- version))
- (go (string-append out "/lib/guile/"
- version "/site-ccache")))
-
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((scm (lambda (in)
+ (string-append in "/share/guile/site/"
+ (target-guile-effective-version))))
+ (ccache (lambda (in)
+ (string-append in "/lib/guile/"
+ (target-guile-effective-version)
+ "/site-ccache")))
+ (pkgs
+ (cons
+ (assoc-ref outputs "out")
+ (filter-map
+ (match-lambda
+ (("guile" . pkg) pkg)
+ ((label . pkg)
+ (and (string-prefix? "guile-" label) pkg)))
+ inputs))))
(substitute* "bin/tsukundere"
- (("exec guile .*" all)
+ (("exec guile (.*)" _ args)
(string-append
- (format #f "export GUILE_LOAD_PATH=~@?~%"
- "\"~a:~a\"" scm (getenv "GUILE_LOAD_PATH"))
- (format #f "export GUILE_LOAD_COMPILED_PATH=~@?~%"
- "\"~a:~a\"" go (getenv "GUILE_LOAD_COMPILED_PATH"))
- all)))
+ (format #f "export GUILE_LOAD_PATH=\"~@?\"~%"
+ "~{~a~^:~}" (map scm pkgs))
+ (format #f "export GUILE_LOAD_COMPILED_PATH=\"~@?\"~%"
+ "~{~a~^:~}" (map ccache pkgs))
+ "exec "
+ (assoc-ref inputs "guile")
+ "/bin/guile " args)))
#t))))))
(native-inputs
`(("autoconf" ,autoconf)
@@ -536,8 +549,9 @@ clone.")
("guile" ,guile-3.0)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
- (propagated-inputs
- `(("guile-sdl2" ,guile3.0-sdl2)))
+ (inputs
+ `(("guile-sdl2" ,guile3.0-sdl2)
+ ("guile" ,guile-3.0)))
(home-page "https://gitlab.com/leoprikler/tsukundere")
(synopsis "Visual novel engine")
(description "Tsukundere is a game engine geared heavily towards the