summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 20:37:14 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:40 +0100
commit1273359455379895e2ae29ddeb9bcaf3f5001a6d (patch)
tree1529b82cc5d646e3ef5d035d096d2b38e430f434 /gnu/packages
parentddd1dc3d2d6728bfe55fb7d9f562556c4992b4f8 (diff)
downloadguix-patches-1273359455379895e2ae29ddeb9bcaf3f5001a6d.tar
guix-patches-1273359455379895e2ae29ddeb9bcaf3f5001a6d.tar.gz
gnu: python2-scikit-image: Remove needless native-input and inheritance.
Remove last additional [native-inputs] python-mock, thus there is no need to inherit python-scikit-image package. Simply use package-with-python2. * gnu/packages/python.scm: (python-scikit-image): [properties]: Remove python2-variant. (python2-scikit-image) Use simply "package-with-python2" after removing last [native-inputs] python-mock.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 00a323fb37..2da510aff2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2974,16 +2974,10 @@ mining and data analysis.")
(synopsis "Image processing in Python")
(description
"Scikit-image is a collection of algorithms for image processing.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-scikit-image))))))
+ (license license:bsd-3)))
(define-public python2-scikit-image
- (let ((scikit-image (package-with-python2
- (strip-python2-variant python-scikit-image))))
- (package (inherit scikit-image)
- (native-inputs
- `(("python2-mock" ,python2-mock)
- ,@(package-native-inputs scikit-image))))))
+ (package-with-python2 python-scikit-image))
(define-public python-redis
(package