summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-14 22:25:15 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:21 +0200
commit0e1b262e054e2378833f6e1d818d8f045a140df7 (patch)
treeeb207acb0142808c05620c2b68650331275f3ff4 /gnu/packages
parent4e4ed0eee8e4d35a6b58a11f3532b108c6bb2a15 (diff)
downloadguix-patches-0e1b262e054e2378833f6e1d818d8f045a140df7.tar
guix-patches-0e1b262e054e2378833f6e1d818d8f045a140df7.tar.gz
gnu: Add lmdb.
* gnu/packages/databases.scm (lmdb): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/databases.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d3a44f7f29..fc31653871 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 David Craven <david@craven.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,6 +58,7 @@
#:use-module ((guix licenses)
#:select (gpl2 gpl3 gpl3+ lgpl2.1+ lgpl3+ x11-style non-copyleft
bsd-2 bsd-3 public-domain))
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -1064,3 +1066,31 @@ trees (LSM), for sustained throughput under random insert workloads.")
(description
"The DB::File module provides Perl bindings to the Berkeley DB version 1.x.")
(license (package-license perl))))
+
+(define-public lmdb
+ (package
+ (name "lmdb")
+ (version "0.9.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/LMDB/lmdb/archive/"
+ "LMDB_" version ".tar.gz"))
+ (sha256
+ (base32
+ "12crvzxky8in99ibh22k4ppmkgqs28yy3v7yy944za7fsrqv8dfx"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chdir (string-append
+ (getenv "PWD") "/lmdb-LMDB_" ,version "/libraries/liblmdb"))
+ (substitute* "Makefile"
+ (("/usr/local") (assoc-ref outputs "out")))
+ #t)))))
+ (home-page "https://symas.com/products/lightning-memory-mapped-database")
+ (synopsis "Lightning memory-mapped database library")
+ (description "Lightning memory-mapped database library.")
+ (license license:openldap2.8)))