summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-05-15 21:42:18 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-17 10:43:15 +0200
commit0d85c83602c58cf83117643571e56205cfaeadc9 (patch)
treef00a037984ea7fe3b54a653561eaf382e17e0b93 /gnu/packages
parent9983dee6b0b4a3ccec263dce6810f06e70b2aba3 (diff)
downloadguix-patches-0d85c83602c58cf83117643571e56205cfaeadc9.tar
guix-patches-0d85c83602c58cf83117643571e56205cfaeadc9.tar.gz
gnu: Add cl-typesetting.
* gnu/packages/lisp-xyz.scm (sbcl-cl-typesetting, ecl-cl-typesetting, cl-typesetting): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7c3b1ecad2..64955a13f6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16608,3 +16608,39 @@ package locks across supported Common Lisp implementations.")
(define-public cl-package-locks
(sbcl-package->cl-source-package sbcl-cl-package-locks))
+
+(define-public sbcl-cl-typesetting
+ (let ((commit "86eba981fc4254addebecf765578ec350d6e3b75")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-typesetting")
+ (version (git-version "0.8.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mbattyani/cl-typesetting")
+ (commit commit)))
+ (file-name (git-file-name "cl-typesetting" version))
+ (sha256
+ (base32 "0fcs5mq0gxfczbrg7ay8r4bf5r4g6blvpdbjkhcl8dapcikyn35h"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; NOTE: (Sharlatan-20210515T213014+0100): Circular dependencies with
+ ;; cl-typegraph
+ `(#:tests? #f))
+ (inputs
+ `(("cl-pdf" ,sbcl-cl-pdf)
+ ("xmls" ,sbcl-xmls)))
+ (home-page "https://github.com/mbattyani/cl-typesetting")
+ (synopsis "Stand-alone Common Lisp typesetting system")
+ (description
+ "CL-TYPESETTING is a cross-platform Common Lisp typesetting library for
+all kind of typesetting applications.")
+ (license license:bsd-2))))
+
+(define-public ecl-cl-typesetting
+ (sbcl-package->ecl-package sbcl-cl-typesetting))
+
+(define-public cl-typesetting
+ (sbcl-package->cl-source-package sbcl-cl-typesetting))