summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-23 13:29:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-23 13:29:30 +0200
commit01dfcad225a2eeca469bfdd665e01c7fb2d28941 (patch)
tree53fe5d9681acb9eb4bfa9bb20765da34dd012b87 /gnu/packages
parent8d428985723dab0e203b965545fb708709a28882 (diff)
downloadguix-patches-01dfcad225a2eeca469bfdd665e01c7fb2d28941.tar
guix-patches-01dfcad225a2eeca469bfdd665e01c7fb2d28941.tar.gz
gnu: Add python-ncls.
* gnu/packages/python-xyz.scm (python-ncls): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 24f08c670e..8b0aae76ac 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1766,6 +1766,26 @@ client-side scripting and application development around the NETCONF
protocol.")
(license license:asl2.0)))
+(define-public python-ncls
+ (package
+ (name "python-ncls")
+ (version "0.0.65")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ncls" version))
+ (sha256
+ (base32
+ "1wx06xqknd2r98w8z93f47g5dpxzn92kamhj8vkq0nj569hf7cg1"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-numpy))
+ (home-page "https://github.com/endrebak/ncls")
+ (synopsis "Nested containment list data structure")
+ (description
+ "This package provides a wrapper for the nested containment list data
+structure. It is a static interval-tree that is fast for both construction
+and lookups.")
+ (license license:bsd-3)))
+
(define-public python-license-expression
(package
(name "python-license-expression")