summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-19 21:37:30 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-19 23:30:11 +0100
commit00ebe4740adf1156772471397222046bd5cb3f40 (patch)
tree65ae1ba867a30270b569f130aa22514a0a06d57d /gnu/packages
parent109da1c08233b59563ab093aae84fceef2555ea5 (diff)
downloadguix-patches-00ebe4740adf1156772471397222046bd5cb3f40.tar
guix-patches-00ebe4740adf1156772471397222046bd5cb3f40.tar.gz
gnu: Move guile-charting to (gnu packages plotutils).
This removes the dependency from (gnu packages guile) to (gnu packages gtk), which potentially reduces the memory/IO/CPU footprint given that 'guile' is used during bootstrap. * gnu/packages/guile.scm (guile-charting): Move to... * gnu/packages/plotutils.scm (guile-charting): ... here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile.scm32
-rw-r--r--gnu/packages/plotutils.scm32
2 files changed, 33 insertions, 31 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index c0c5ced0f3..f71201b553 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -34,7 +34,6 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages ed)
#:use-module (gnu packages which)
- #:use-module (gnu packages gtk)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -368,33 +367,4 @@ http:://json.org specification. These are the main features:
- Allows JSON pretty printing.")
(license lgpl3+)))
-(define-public guile-charting
- (package
- (name "guile-charting")
- (version "0.2.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://wingolog.org/pub/guile-charting/"
- "guile-charting-" version ".tar.gz"))
- (sha256
- (base32
- "0w5qiyv9v0ip5li22x762bm48g8xnw281w66iyw094zdw611pb2m"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Use the standard location for modules.
- (substitute* "Makefile.in"
- (("godir = .*$")
- "godir = $(moddir)\n"))))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("guile" ,guile-2.0)))
- (propagated-inputs `(("guile-cairo" ,guile-cairo)))
- (home-page "http://wingolog.org/software/guile-charting/")
- (synopsis "Create charts and graphs in Guile")
- (description
- "Guile-Charting is a Guile Scheme library to create bar charts and graphs
-using the Cairo drawing library.")
- (license lgpl2.1+)))
-
;;; guile.scm ends here
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 41df88088e..da40e28334 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -23,6 +23,9 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages xorg)
#:use-module (gnu packages image)
+ #:use-module (gnu packages guile)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages))
(define-public plotutils
@@ -62,3 +65,32 @@ graphics in many file formats. It also has support for 2D vector graphics
animations. The package also contains command-line programs for plotting
scientific data.")
(license gpl2+)))
+
+(define-public guile-charting
+ (package
+ (name "guile-charting")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://wingolog.org/pub/guile-charting/"
+ "guile-charting-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0w5qiyv9v0ip5li22x762bm48g8xnw281w66iyw094zdw611pb2m"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Use the standard location for modules.
+ (substitute* "Makefile.in"
+ (("godir = .*$")
+ "godir = $(moddir)\n"))))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("guile" ,guile-2.0)))
+ (propagated-inputs `(("guile-cairo" ,guile-cairo)))
+ (home-page "http://wingolog.org/software/guile-charting/")
+ (synopsis "Create charts and graphs in Guile")
+ (description
+ "Guile-Charting is a Guile Scheme library to create bar charts and graphs
+using the Cairo drawing library.")
+ (license lgpl2.1+)))