summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-13 09:02:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-13 09:02:56 +0300
commit000498784f4aae34742b28e72175cebce4cff01e (patch)
treee1e675adb10c3622b3e7aba08edac13c8f07b2d0 /gnu/packages
parent5cd9cd644ca493b230cb229e7c46641e94a4e2fa (diff)
downloadguix-patches-000498784f4aae34742b28e72175cebce4cff01e.tar
guix-patches-000498784f4aae34742b28e72175cebce4cff01e.tar.gz
gnu: libreoffice: Update to 6.4.5.2.
* gnu/packages/libreoffice.scm (libreoffice): Update to 6.4.5.2. [source]: Remove patch. * gnu/packages/patches/libreoffice-poppler-compat.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/libreoffice.scm5
-rw-r--r--gnu/packages/patches/libreoffice-poppler-compat.patch19
2 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a98ae152f6..ebe4fd7246 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1049,7 +1049,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "6.4.4.2")
+ (version "6.4.5.2")
(source
(origin
(method url-fetch)
@@ -1057,10 +1057,9 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(string-append
"https://download.documentfoundation.org/libreoffice/src/"
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
- (patches (search-patches "libreoffice-poppler-compat.patch"))
(sha256
(base32
- "0y6026h374787yy2f3as1q7clxmgywsfdrj62kw3577wvybqaf2l"))))
+ "1v4ili9j8d0xfj3q69niski1v65icg8xi09ip2bsk343rawwck3a"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("bison" ,bison)
diff --git a/gnu/packages/patches/libreoffice-poppler-compat.patch b/gnu/packages/patches/libreoffice-poppler-compat.patch
deleted file mode 100644
index 8dc0b60a12..0000000000
--- a/gnu/packages/patches/libreoffice-poppler-compat.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Fix type mismatch with Poppler 0.86.
-
-Taken from Arch Linux:
-https://git.archlinux.org/svntogit/packages.git/tree/trunk/libreoffice-poppler-0.86.patch?h=packages/libreoffice-fresh
-
-diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
---- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
-+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
-@@ -563,7 +563,9 @@ void PDFOutDev::processLink(Link* link, Catalog*)
- if (!(pAction && pAction->getKind() == actionURI))
- return;
-
--#if POPPLER_CHECK_VERSION(0, 72, 0)
-+#if POPPLER_CHECK_VERSION(0, 86, 0)
-+ const char* pURI = static_cast<LinkURI*>(pAction)->getURI().c_str();
-+#elif POPPLER_CHECK_VERSION(0, 72, 0)
- const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
- #else
- const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();