summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 22:34:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 23:17:35 +0100
commit63f3255e13be8d1352031c78a37131c2c6644bdb (patch)
treec648985d2db96cfa63aecb91a0a80501dc8c931c /gnu/packages
parent019fcdf20af9de5860d7005fe5fb7adef222ce59 (diff)
downloadguix-patches-63f3255e13be8d1352031c78a37131c2c6644bdb.tar
guix-patches-63f3255e13be8d1352031c78a37131c2c6644bdb.tar.gz
gnu: seqtk: Update to 1.3.
* gnu/packages/bioinformatics.scm (seqtk): Update to 1.3. [source]: Remove outdated snippet. [arguments]: Use INVOKE and return #T unconditionally.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b98be8eb51..670bea5cd4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5868,7 +5868,7 @@ is one that takes arguments.")
(define-public seqtk
(package
(name "seqtk")
- (version "1.2")
+ (version "1.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5877,15 +5877,7 @@ is one that takes arguments.")
(file-name (git-file-name name version))
(sha256
(base32
- "1mdkgmzdy734a0na9hxbl4k41jjkm87bvjbm7bdbh50fsra86f93"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove extraneous header files, as is done in the seqtk
- ;; master branch.
- (for-each (lambda (file) (delete-file file))
- (list "ksort.h" "kstring.h" "kvec.h"))
- #t))))
+ "1bfzlqa84b5s1qi22blmmw2s8xdyp9h9ydcq22pfjhh5gab3yz6l"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -5893,11 +5885,12 @@ is one that takes arguments.")
(delete 'configure)
(replace 'check
;; There are no tests, so we just run a sanity check.
- (lambda _ (zero? (system* "./seqtk" "seq"))))
+ (lambda _ (invoke "./seqtk" "seq") #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
- (install-file "seqtk" bin)))))))
+ (install-file "seqtk" bin)
+ #t))))))
(inputs
`(("zlib" ,zlib)))
(home-page "https://github.com/lh3/seqtk")