summaryrefslogtreecommitdiff
path: root/gnu/packages/zwave.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/zwave.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/zwave.scm')
-rw-r--r--gnu/packages/zwave.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/zwave.scm b/gnu/packages/zwave.scm
index 2019ec32df..4d8286e334 100644
--- a/gnu/packages/zwave.scm
+++ b/gnu/packages/zwave.scm
@@ -74,12 +74,9 @@
;; the device XML database and it's not entirely clear what to get from
;; them.
#:tests? #f))
- (native-inputs `(("which" ,which)
- ("pkg-config" ,pkg-config)
- ("perl" ,perl) ;for tests
- ("perl-xml-simple" ,perl-xml-simple)))
- (inputs `(("hidapi" ,hidapi)
- ("eudev" ,eudev)))
+ (native-inputs (list which pkg-config perl ;for tests
+ perl-xml-simple))
+ (inputs (list hidapi eudev))
(home-page "http://www.openzwave.net/")
(synopsis "Access Z-Wave devices from C++ programs")
(description