summaryrefslogtreecommitdiff
path: root/gnu/packages/zile.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-19 17:08:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-19 17:10:17 +0300
commitc11933c920dd7b7cdf68e13e6b3718602129210a (patch)
tree39915c2ca72af8fa38c62cf95f64e8e13d3b459d /gnu/packages/zile.scm
parentfa216a4d017828819ae4c3e25b3f69e07729f046 (diff)
downloadguix-patches-c11933c920dd7b7cdf68e13e6b3718602129210a.tar
guix-patches-c11933c920dd7b7cdf68e13e6b3718602129210a.tar.gz
gnu: zile: Use 'modify-phases' syntax.
* gnu/packages/zile.scm (zile)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/zile.scm')
-rw-r--r--gnu/packages/zile.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/zile.scm b/gnu/packages/zile.scm
index 88aaf75c50..13a5440eea 100644
--- a/gnu/packages/zile.scm
+++ b/gnu/packages/zile.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,15 +43,16 @@
"03mcg0bxkzprlsx8y6h22w924pzx4a9zr7zm3g11j8j3x9lz75f7"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'configure 'patch-/bin/sh
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (assoc-ref inputs "bash")))
- ;; Refer to the actual shell.
- (substitute* '("lib/spawni.c" "src/funcs.c")
- (("/bin/sh")
- (string-append bash "/bin/sh")))))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-/bin/sh
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ ;; Refer to the actual shell.
+ (substitute* '("lib/spawni.c" "src/funcs.c")
+ (("/bin/sh")
+ (string-append bash "/bin/sh")))
+ #t))))))
(inputs
`(("boehm-gc" ,libgc)
("ncurses" ,ncurses)