summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-07 11:04:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-07 14:19:08 +0200
commitd9dfbf886ddbb92dfdaa118bb9765e78aad5c53a (patch)
tree2732020de20a38c09b66a60b0cb36022799f7c2e /gnu/packages/xorg.scm
parentb949f34f31a045eb0fb242b81a223178fb6994d3 (diff)
parent49922efb11da0f0e9d4f5979d081de5ea8c99d25 (diff)
downloadguix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar
guix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm57
1 files changed, 43 insertions, 14 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index def751c62c..15e568029b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4429,17 +4429,14 @@ and Reflect (RandR) extension.")
(define-public xrdb
(package
(name "xrdb")
- (version "1.2.0")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/app/xrdb-"
- version
- ".tar.bz2"))
+ (uri (string-append "mirror://xorg/individual/app/xrdb-"
+ version ".tar.bz2"))
(sha256
- (base32
- "0ik9gh6363c47pr0dp7q22nfs8vmavjg2v4bsr0604ppl77nafpj"))))
+ (base32 "1d78prd8sfszq2rwwlb32ksph4fymf988lp75aj8iysg44f06pag"))))
(build-system gnu-build-system)
(inputs
`(("libxmu" ,libxmu)
@@ -4602,17 +4599,14 @@ extension.")
(define-public xwd
(package
(name "xwd")
- (version "1.0.7")
+ (version "1.0.8")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/app/xwd-"
- version
- ".tar.bz2"))
+ (uri (string-append "mirror://xorg/individual/app/xwd-"
+ version ".tar.bz2"))
(sha256
- (base32
- "1537i8q8pgf0sjklakzfvjwrq5b246qjywrx9ll8xfg0p6w1as6d"))))
+ (base32 "06q36fh55r62ms0igfxsanrn6gv8lh794q1bw9xzw51p2qs2papv"))))
(build-system gnu-build-system)
(inputs
`(("libxt" ,libxt)
@@ -6941,3 +6935,38 @@ an existing user-specified one, writes a cookie to it, and then starts the
the server and cleaning up before returning the exit status of the command.")
(license (list license:x11 ; the script
license:gpl2+)))) ; the man page
+
+(define-public setroot
+ (package
+ (name "setroot")
+ (version "2.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ttzhou/setroot")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w95828v0splk7bj5kfacp4pq6wxpyamvyjmahyvn5hc3ycq21mq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "PREFIX="
+ "xinerama=1")
+ #:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("libx11" ,libx11)
+ ("libxinerama" ,libxinerama)))
+ (home-page "https://github.com/ttzhou/setroot")
+ (synopsis "Simple X background setter inspired by imlibsetroot and feh")
+ (description "Setroot is a lightweight X background setter with feh's
+syntax without its image viewing capabilities. It supports multiple monitors
+and can restore previously set wallpapers and options.")
+ (license license:gpl3+)))