summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-11 17:08:49 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-11 18:14:07 +0200
commitc1d7eac34644102d38272c6cf02d50661f4ba5c8 (patch)
tree5386ee326215198aa2871be1a3bc16965c12e0e4 /gnu/packages/xorg.scm
parent7be2b83102e477133cfdb9db6eac266da8c6140f (diff)
downloadguix-patches-c1d7eac34644102d38272c6cf02d50661f4ba5c8.tar
guix-patches-c1d7eac34644102d38272c6cf02d50661f4ba5c8.tar.gz
gnu: xkbcomp-intermediate: Export variable.
* gnu/packages/xorg.scm (xkbcomp-intermediate): Make public. [properties]: New field. (xkbcomp)[properties]: New field.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 15e568029b..95d3442d36 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3931,7 +3931,7 @@ alternative implementations like XRandR or TwinView.")
(license license:x11)))
-(define xkbcomp-intermediate ;used as input for xkeyboard-config
+(define-public xkbcomp-intermediate ;used as input for xkeyboard-config
(package
(name "xkbcomp-intermediate")
(version "1.4.5")
@@ -3964,11 +3964,16 @@ explicitly specify most aspects of keyboard behaviour on per-key basis
and to more closely track the logical and physical state of the
keyboard. It also includes a number of keyboard controls designed to
make keyboards more accessible to people with physical impairments.")
- (license license:x11)))
+ (license license:x11)
+
+ ;; The only reason this package is public is to make sure it's built and
+ ;; published by the continuous integration tool.
+ (properties '((hidden? . #t)))))
(define-public xkbcomp ; using xkeyboard-config as input
(package (inherit xkbcomp-intermediate)
(name "xkbcomp")
+ (properties '())
(inputs
`(,@(package-inputs xkbcomp-intermediate)
("xkeyboard-config" ,xkeyboard-config)))