summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-26 17:55:43 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-26 18:13:21 +0100
commitadf218e2e8d855ca9c8477658478658939ed2107 (patch)
tree6f70e4408b1906e4965cd3ce14891a2e1d2ee31e /gnu/packages/xorg.scm
parent7681436bfd9c3b6d9b8d18a1c81102d14378cbe8 (diff)
downloadguix-patches-adf218e2e8d855ca9c8477658478658939ed2107.tar
guix-patches-adf218e2e8d855ca9c8477658478658939ed2107.tar.gz
gnu: libxt: Fix cross-compilation.
* gnu/packages/xorg.scm (libxt)[arguments]: Pass --disable-malloc0returnsnull configure flag when cross-compiling.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 801e5e459b..b3792122ac 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5411,10 +5411,15 @@ draggable titlebars and borders.")
(outputs '("out"
"doc")) ;2 MiB of man pages + XML
(arguments
- '(#:configure-flags (list (string-append "--mandir="
- (assoc-ref %outputs "doc")
- "/share/man")
- "--disable-static")))
+ `(#:configure-flags
+ (list (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man")
+ "--disable-static"
+ ;; Disable zero malloc check that fails when cross-compiling.
+ ,@(if (%current-target-system)
+ '("--disable-malloc0returnsnull")
+ '()))))
(propagated-inputs
`(("libx11" ,libx11)
("libice" ,libice)