summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-02-22 13:18:17 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-03-13 13:43:06 +0530
commitacf6168b5dd1d5f03ad22966b27540d4457d2863 (patch)
treef396effee2c4dee3fedc2ce8969e1ce55234222b /gnu/packages/xorg.scm
parentd1548cb09f9294d0c68e2eb54f2f27a594b84fe2 (diff)
downloadguix-patches-acf6168b5dd1d5f03ad22966b27540d4457d2863.tar
guix-patches-acf6168b5dd1d5f03ad22966b27540d4457d2863.tar.gz
gnu: uim: Do not install elisp files in guix.d.
* gnu/packages/xorg.scm (uim)[arguments]: Pass %output/share/emacs to the --with-lispdir configure flag. Add fix-install-path phase after install phase.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f951e565ff..a7ba6fe9eb 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016, 2017 John Darrington <jmd@gnu.org>
;;; Copyright © 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
@@ -6137,8 +6137,7 @@ X11 servers, Windows, or macOS.")
(guix build emacs-utils))
#:configure-flags
(list "--with-anthy-utf8"
- (string-append "--with-lispdir=" %output
- "/share/emacs/site-lisp/guix.d")
+ (string-append "--with-lispdir=" %output "/share/emacs")
;; Set proper runpath
(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
#:phases
@@ -6151,8 +6150,17 @@ X11 servers, Windows, or macOS.")
(string-append "\"" (assoc-ref outputs "out")
"/bin/" executable "\"")))
#t))
+ ;; Fix installation path by renaming share/emacs/uim-el to
+ ;; share/emacs/site-lisp
+ (add-after 'install 'fix-install-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((share-emacs (string-append (assoc-ref outputs "out")
+ "/share/emacs")))
+ (rename-file (string-append share-emacs "/uim-el")
+ (string-append share-emacs "/site-lisp")))
+ #t))
;; Generate emacs autoloads for uim.el
- (add-after 'install 'make-autoloads
+ (add-after 'fix-install-path 'make-autoloads
(lambda* (#:key outputs #:allow-other-keys)
(emacs-generate-autoloads
,name (string-append (assoc-ref outputs "out")