summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-01-07 08:44:29 +0100
committerLars-Dominik Braun <lars@6xq.net>2022-01-07 08:58:40 +0100
commit927c58925667eabdcd07a9dc68e283ef0f6b6b0e (patch)
tree15fc3296b1be23ba08f7f5b30039b4f1f613fc61 /gnu/packages/xorg.scm
parent05b0491d0646508336fbf455a31367745d5e5b45 (diff)
downloadguix-patches-927c58925667eabdcd07a9dc68e283ef0f6b6b0e.tar
guix-patches-927c58925667eabdcd07a9dc68e283ef0f6b6b0e.tar.gz
gnu: xpra: Install Cython-built libraries.
xpra would fail to start, because shared objects were not installed. It’s not clear why it stopped working, but it seems it was not the upgrade I reverted in commit ab6d56d01d62757caa66fe0a23e8864c9122f0e6 to fix #52869. Sorry for the confusion :( * gnu/packages/patches/xpra-4.2-install_libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/xorg.scm (xpra)[source]: Add new patch. [arguments]: Ensure 'build phase runs and passes #:configure-flags to setup.py.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f341ccce8c..79d9be9420 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6323,7 +6323,8 @@ basic eye-candy effects.")
version ".tar.gz"))
(sha256
(base32 "0nky9j07zq8d5ifx568dima7a0jgs8kwhcqbg8p6gsxlgq5zdw96"))
- (patches (search-patches "xpra-4.2-systemd-run.patch"))))
+ (patches (search-patches "xpra-4.2-systemd-run.patch"
+ "xpra-4.2-install_libs.patch"))))
(build-system python-build-system)
;; see also http://xpra.org/trac/wiki/Dependencies
(inputs `(("bash-minimal" ,bash-minimal) ; for wrap-program
@@ -6374,8 +6375,12 @@ basic eye-candy effects.")
; they seem to require python2.
#:phases
(modify-phases %standard-phases
- ;; built by 'install phase
- (delete 'build)
+ ;; Must pass the same flags as 'install, otherwise enabled modules may
+ ;; not be built.
+ (replace 'build
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ (apply invoke (append (list "python" "setup.py" "build")
+ configure-flags))))
(add-before 'install 'fix-paths
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Fix binary paths.