summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2022-01-01 03:35:32 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2022-01-01 20:23:35 +0300
commit7edc70ee2707ddf7822f5023a462a91debcbce4c (patch)
tree2952f44a5ec64c4ce866aace714f8c659bfc1a18 /gnu/packages/xorg.scm
parentdf78f622791ea6f832ce0c54f6aaf8f6e58319d1 (diff)
downloadguix-patches-7edc70ee2707ddf7822f5023a462a91debcbce4c.tar
guix-patches-7edc70ee2707ddf7822f5023a462a91debcbce4c.tar.gz
gnu: Add libxpresent.
* gnu/packages/xorg.scm (libxpresent): New variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b09d95f770..fcaae30664 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2017, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018, 2020, 2022 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2019 nee <nee@cock.li>
;;; Copyright © 2019 Yoshinori Arai <kumagusu08@gmail.com>
@@ -6002,6 +6002,27 @@ user-friendly mechanism to start the X server.")
Intrinsics (Xt) Library.")
(license license:x11)))
+(define-public libxpresent
+ (package
+ (name "libxpresent")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri "mirror://xorg/individual/lib/libXpresent-1.0.0.tar.bz2")
+ (sha256
+ (base32
+ "12kvvar3ihf6sw49h6ywfdiwmb8i1gh8wasg1zhzp6hs2hay06n1"))))
+ (inputs
+ (list libx11 xorgproto libxext libxfixes libxrandr))
+ (native-inputs
+ (list pkg-config))
+ (build-system gnu-build-system)
+ (home-page "https://gitlab.freedesktop.org/xorg/lib/libxpresent")
+ (synopsis "Xlib-compatible API for the Present extension")
+ (description "This package provides a Xlib-based library for the X Present
+Extension.")
+ (license license:x11)))
+
(define-public xclock
(package
(name "xclock")