summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-18 23:52:34 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-20 08:57:01 -0500
commit7063ee6d9de6524f25dce18e20cd0356f0272063 (patch)
treecbe741b7884ee029f614dfa9c30cacd0b1ebacd8 /gnu/packages/xorg.scm
parent8444b44a8c7ae67c11dee22f99b0a7b6a431d29d (diff)
downloadguix-patches-7063ee6d9de6524f25dce18e20cd0356f0272063.tar
guix-patches-7063ee6d9de6524f25dce18e20cd0356f0272063.tar.gz
gnu: libxcursor: Add a search path for XCURSOR_PATH.
* gnu/packages/xorg.scm (libxcursor): Fix indentation. [native-search-paths]: New field (previously commented). Update comment.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm43
1 files changed, 20 insertions, 23 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index cefd0988be..043e023ab2 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5715,34 +5715,31 @@ Wayland.")
(name "libxcursor")
(version "1.2.0")
(source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/lib/libXcursor-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "10l7c9fm0jmpkm9ab9dz8r6m1pr87vvgqjnbx1psz50h4pwfklrs"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/lib/libXcursor-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "10l7c9fm0jmpkm9ab9dz8r6m1pr87vvgqjnbx1psz50h4pwfklrs"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static")))
(propagated-inputs
- `(("libx11" ,libx11)
- ("libxrender" ,libxrender)
- ("libxfixes" ,libxfixes)
- ("xorgproto" ,xorgproto)))
+ `(("libx11" ,libx11)
+ ("libxrender" ,libxrender)
+ ("libxfixes" ,libxfixes)
+ ("xorgproto" ,xorgproto)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
-;; TODO: add XCURSOR_PATH=.../share/icons to profile search paths, so
-;; libXcursor finds cursors installed into a profile. If we solve bugs
-;; <http://bugs.gnu.org/20255> and <http://bugs.gnu.org/22138>, we can fix
-;; this with a search-path as follows:
-;;
-;; (native-search-paths
-;; (list (search-path-specification
-;; (variable "XCURSOR_PATH")
-;; (files '("share/icons")))))
+ `(("pkg-config" ,pkg-config)))
+ ;; FIXME: The search path below won't be very effective until the bugs
+ ;; <http://bugs.gnu.org/20255> and <http://bugs.gnu.org/22138> are solved.
+ (native-search-paths
+ (list (search-path-specification
+ (variable "XCURSOR_PATH")
+ (files '("share/icons")))))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg Cursor management library")
(description "Xorg Cursor management library.")