summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-11 20:27:38 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-13 21:58:33 +0000
commit37c84d077421692fea9ad69e935adbc00bac3b4c (patch)
tree3b1b73e67cfa4841857105bfe5cc4aba5aae8c31 /gnu/packages/xorg.scm
parent6ff98ce39780ccef5f83aa94f14d0f742f8ea568 (diff)
downloadguix-patches-37c84d077421692fea9ad69e935adbc00bac3b4c.tar
guix-patches-37c84d077421692fea9ad69e935adbc00bac3b4c.tar.gz
gnu: perl-x11-xcb: Update to 0.19.
* gnu/packages/xorg.scm (perl-x11-xcb): Update to 0.19. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index e794a422c7..587e9ccff0 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6174,7 +6174,7 @@ programs that cannot use the window system directly.")
(define-public perl-x11-xcb
(package
(name "perl-x11-xcb")
- (version "0.18")
+ (version "0.19")
(source (origin
(method url-fetch)
(uri (string-append
@@ -6182,7 +6182,7 @@ programs that cannot use the window system directly.")
"X11-XCB-" version ".tar.gz"))
(sha256
(base32
- "1cjpghw7cnackw20lbd7yzm222kz5bnrwz52f8ay24d1f4pwrnxf"))))
+ "1rn8g0yy82v5zp12rhxic332dvqs63l7mykg028ngvccs7rllipp"))))
(build-system perl-build-system)
(arguments
'(;; Disable parallel build to prevent a race condition.
@@ -6193,8 +6193,7 @@ programs that cannot use the window system directly.")
(lambda _
(setenv "PERL5LIB"
(string-append (getcwd) ":"
- (getenv "PERL5LIB")))
- #t))
+ (getenv "PERL5LIB")))))
(add-before 'build 'patch-Makefile
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile"
@@ -6202,8 +6201,7 @@ programs that cannot use the window system directly.")
;; an error such as "XCB.so: undefined symbol: xcb_xinerama_id"
(("^LDDLFLAGS = ")
(string-append "LDDLFLAGS = "
- "-lxcb -lxcb-util -lxcb-xinerama -lxcb-icccm ")))
- #t)))
+ "-lxcb -lxcb-util -lxcb-xinerama -lxcb-icccm "))))))
;; Tests require a running X11 server.
#:tests? #f))
(native-inputs