summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-05 15:50:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:35 -0500
commit2541a0527e7406d52562508c998cac9d526c290b (patch)
tree74db5ec5469763bff3bc256ac3f51b7dbb31f18e /gnu/packages/xorg.scm
parentf82cb5b57def732367702ab2a94d0e018a756952 (diff)
downloadguix-patches-2541a0527e7406d52562508c998cac9d526c290b.tar
guix-patches-2541a0527e7406d52562508c998cac9d526c290b.tar.gz
gnu: hackneyed-x11-cursors: Update to 0.8.2.
* gnu/packages/xorg.scm (hackneyed-x11-cursors): Update to 0.8.2.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm104
1 files changed, 49 insertions, 55 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3d431e0005..574562f065 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2274,64 +2274,58 @@ X11 Inter-Client Communication Conventions Manual (ICCCM).")
X server: @code{handhelds}, @code{redglass} and @code{whiteglass}.")
(license license:x11)))
-
(define-public hackneyed-x11-cursors
- ;; The current release 0.8 suffers from non-deterministic build problems.
- (let ((revision "1")
- (commit "9423cef2e2e5ff6b1d65d61f7108c97bc7f5fdfb"))
- (package
- (name "hackneyed-x11-cursors")
- (version (git-version "0.8.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/Enthymeme/hackneyed-x11-cursors.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0f637i76sdwz3nm1g1iynamq6j0i6k3c70fpl0fmd0dlynm8ga96"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ;no test suite
- #:make-flags (list (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'set-inkscape-environment-variable
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((inkscape (search-input-file inputs "/bin/inkscape")))
- (setenv "INKSCAPE" inkscape)
- #t)))
- (add-before 'build 'placate-inkscape-warnings
- (lambda _
- (setenv "HOME" (getcwd))
- #t))
- (add-after 'build 'generate-black-cursors
- (lambda* (#:key make-flags parallel-build #:allow-other-keys)
- (let ((build (assoc-ref %standard-phases 'build))
- (make-flags/extended
- `(,@make-flags
- "THEME_NAME=Hackneyed-Dark"
- "COMMON_SOURCE=theme/common-dark.svg"
- "RSVG_SOURCE=theme/right-handed-dark.svg"
- "LSVG_SOURCE=theme/left-handed-dark.svg")))
- (build #:make-flags make-flags/extended
- #:parallel-build parallel-build))))
- (add-after 'install 'install-black-cursors
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke `("make" "install" ,@make-flags
- "THEME_NAME=Hackneyed-Dark")))))))
- (native-inputs `(("imagemagick" ,imagemagick)
- ("inkscape" ,inkscape)
- ("xcursorgen" ,xcursorgen)))
- (home-page "https://gitlab.com/Enthymeme/hackneyed-x11-cursors")
- (synopsis "Classic cursor theme for X11")
- (description "Hackneyed is a scalable cursor theme mildly resembling old
+ (package
+ (name "hackneyed-x11-cursors")
+ (version "0.8.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/Enthymeme/hackneyed-x11-cursors.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mjwbny4rid9dzz6xfb8l5rkwki41sfhdp970cf3w2pi9kyg1njs"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:make-flags (list (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'set-inkscape-environment-variable
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((inkscape (search-input-file inputs "/bin/inkscape")))
+ (setenv "INKSCAPE" inkscape))))
+ (add-before 'build 'placate-inkscape-warnings
+ (lambda _
+ (setenv "HOME" (getcwd))))
+ (add-after 'build 'generate-black-cursors
+ (lambda* (#:key make-flags parallel-build #:allow-other-keys)
+ (let ((build (assoc-ref %standard-phases 'build))
+ (make-flags/extended
+ `(,@make-flags
+ "THEME_NAME=Hackneyed-Dark"
+ "COMMON_SOURCE=theme/common-dark.svg"
+ "RSVG_SOURCE=theme/right-handed-dark.svg"
+ "LSVG_SOURCE=theme/left-handed-dark.svg")))
+ (build #:make-flags make-flags/extended
+ #:parallel-build parallel-build))))
+ (add-after 'install 'install-black-cursors
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke `("make" "install" ,@make-flags
+ "THEME_NAME=Hackneyed-Dark")))))))
+ (native-inputs `(("imagemagick" ,imagemagick)
+ ("inkscape" ,inkscape)
+ ("xcursorgen" ,xcursorgen)))
+ (home-page "https://gitlab.com/Enthymeme/hackneyed-x11-cursors")
+ (synopsis "Classic cursor theme for X11")
+ (description "Hackneyed is a scalable cursor theme mildly resembling old
Windows 3.x cursors. The cursors are available in white and black colors. A
left-handed version of the cursors is also included.")
- (license license:x11))))
+ (license license:x11)))
(define-public xcursorgen
(package